WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 8 months ago

#37315 closed defect (bug) (invalid)

Underscores are not visible for inputs marked .code or code element

Reported by: andreasnrb Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords: needs-patch
Focuses: ui, administration Cc:

Description

The .code, code CSS in common.css uses font-family: Consolas, Monaco, monospace. On Ubuntu with Chrome (haven't tested others) the _ and perhaps other characters are invisible. Changing to Arial reintroduces the _.

Attachments (1)

no_underscores_in_field.png (9.0 KB) - added by andreasnrb 5 years ago.

Download all attachments as: .zip

Change History (7)

#1 follow-up: @andreasnrb
5 years ago

Perhaps this belongs to #36753 ?

#2 in reply to: ↑ 1 @helen
5 years ago

  • Keywords reporter-feedback added

Replying to andreasnrb:

Perhaps this belongs to #36753 ?

Seems unlikely, as that did not touch this font stack. Changing to Arial defeats the purpose of the code styling - looks like maybe an input height issue. This doesn't happen in 4.5?

#3 @SergeyBiryukov
5 years ago

  • Component changed from General to Administration
  • Focuses ui administration added

#4 @andreasnrb
5 years ago

  • Component changed from Administration to General
  • Focuses ui administration removed
  • Keywords reporter-feedback removed

It was a line-height issue. Changing height did not help. Changing line-height from normal to >1.3 fixes issue for me. Issue is in 4.5 as well.

#5 @ocean90
5 years ago

  • Focuses ui administration added
  • Keywords needs-patch added
  • Version trunk deleted

#6 @desrosj
8 months ago

  • Resolution set to invalid
  • Status changed from new to closed

I do not have access to an Ubuntu set up to attempt to reproduce. However, the line height on input fields was bumped up to 2 in [46356] as a part of #47477 instead of the normal value that an input with the .code class was receiving in version 4.5 (the calculated value on MacOS using Firefox shows as 1.5).

Because the testing above showed larger line-height values fixed the issue, I'm going to close this one out. If someone is still able to reproduce, feel free to reopen with some updated information to reproduce the issue. (I'm using the invalid resolution because the others did not fit either)

Note: See TracTickets for help on using tickets.