WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#37351 closed defect (bug) (duplicate)

Already installed plugin shows with "Install Now" button on plugin-install.php page

Reported by: mapk Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0
Component: Plugins Keywords:
Focuses: ui Cc:
PR Number:

Description

I have the plugin Hello Dolly already installed, just not activated. When I search for that plugin in the "Add New Plugin" plugin-install.php page, it shows up with a button to "Install Now". Shouldn't it detect my installation and show "Installed" or "Activate" instead?

Already installed plugin
https://cldup.com/QmXjlv7XxG.png

But shows as needing to be installed on plugin-install.php
https://cldup.com/_yumIShg6w.png

Change History (3)

#1 @swissspidy
3 years ago

  • Summary changed from Shiny Updates: Already intalled plugin shows with "Install Now" button on plugin-install.php page to Already intalled plugin shows with "Install Now" button on plugin-install.php page
  • Version changed from trunk to 3.0

I assume the already installed plugin is wp-content/plugins/hello.php, which gets shipped with every WordPress site by default.

On the plugin-install.php screen, Hello Dolly is displayed as not being installed because install_plugin_install_status() checks if the wp-content/plugins/hello-dolly/ directory exists. Obviously it doesn't, because it's just a PHP file. Therefore you're able to install the plugin from WordPress.org.

Technically those are separate plugins that happen to have the same name. It's like having a GitHub checkout from WooCommerce inside wp-content/plugins/woocommerce-master. You can still download it from WordPress.org

#2 @swissspidy
3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #29540.

#3 @DrewAPicture
3 years ago

  • Summary changed from Already intalled plugin shows with "Install Now" button on plugin-install.php page to Already installed plugin shows with "Install Now" button on plugin-install.php page
Note: See TracTickets for help on using tickets.