WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#37352 closed enhancement (duplicate)

Change get_option with stylesheet and template to get_stylesheet() and get_template()

Reported by: sebastian.pisula Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Themes Keywords:
Focuses: Cc:
PR Number:

Description

Change get_option with stylesheet and template to get_stylesheet() and get_template()

In my plugin I must use 4 filters but I should use two:

add_filter( 'template', array( $this, 'template_stylesheet' ) );
add_filter( 'stylesheet', array( $this, 'template_stylesheet' ) );
add_filter( 'pre_option_template', array( $this, 'template_stylesheet' ) );
add_filter( 'pre_option_stylesheet', array( $this, 'template_stylesheet' ) );

Attachments (1)

37352.patch (3.3 KB) - added by sebastian.pisula 3 years ago.

Download all attachments as: .zip

Change History (2)

#1 @ocean90
3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #20027.

Note: See TracTickets for help on using tickets.