WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 20 months ago

#37396 closed defect (bug) (invalid)

Plugin update never finishes (PHP 7, possibly due to configuration)

Reported by: miyarakira Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.5.3
Component: Filesystem API Keywords:
Focuses: Cc:

Description

Running on PHP 7, I noticed that I'm not able to update plugins - the spinner spins and it never completes the update.

I traced it from admin-ajax to class-wp-upgrader and finally to class-wp-filesystem-direct.php.

Inside the function dirlist(), two lines which get the owner and group of (in this case) the temporary directory were getting "stuck".

With the following changes, I was able to get the plugin update process to complete successfully:

  1. Inside public function owner(), return the owner ID instead of using posix_getpwuid.
  1. Inside public function group(), return the group ID instead of using posix_getgrgid.

So, these two POSIX functions seem to be the cause, although I couldn't figure out why. Since this is happening in an AJAX response, I had a hard time debugging it. It could be due to a wrong server configuration on my part. The issue does not occur on previous versions of PHP, i.e., 5.4.

Change History (3)

#1 @desrosj
20 months ago

  • Component changed from Plugins to Filesystem API
  • Keywords reporter-feedback close added

Hi @miyarakira,

My apologies that it took so long to get a response on this one.

Are you still experiencing this issue? Are you able to provide steps to reproduce this? As far as I can tell, this was not something that was widely reported.

I am going to mark as a close candidate pending your feedback.

Potentially related: #37978.

#2 @miyarakira
20 months ago

Hi @desrosj,

Thank you for getting back to this ticket.

The issue was resolved at the time. I don't recall the details, but I believe it was due to wrong server configuration.

So, yes, the ticket can be closed.

#3 @desrosj
20 months ago

  • Keywords reporter-feedback close removed
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Thanks, @miyarakira. Appreciate the follow up!

Note: See TracTickets for help on using tickets.