WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 21 months ago

#37408 closed feature request (duplicate)

Create optimized Image even if image size equals original image

Reported by: HKandulla Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.6
Component: Media Keywords:
Focuses: Cc:

Description

Hi,

at the moment WP creates optimized and scaled images for all sizes - supplied by add_image_size() - that are smaller than the original image.
I think it would be much better if WP creates images for all sizes that are smaller or equal the original system.
Example:
We buy/upload images in 620x340px and we display the image in 620x340px, so we added:

<?php
add_image_size('620x340', 620, 340, true)

At the moment WP uses the original image and there is no clean way of displaying the optinzed version of this image.

I would be happy to create a PR for this change, if I knew it would make into core.

Please let me know what you think.#

Thanks, Hannes

Change History (3)

#1 @swissspidy
21 months ago

  • Component changed from Upload to Media

This ticket was mentioned in Slack in #core-media by desrosj. View the logs.


21 months ago

#3 @desrosj
21 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Hi @HKandulla, thanks for the ticket and welcome to Trac!

I am going to close this out as a duplicate of #37840. There is much more progress there. Feel free to chime in and help with testing on that ticket.

Note: See TracTickets for help on using tickets.