WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#37427 closed defect (bug) (fixed)

wpView not working well in IE and iOS Safari

Reported by: azaozz Owned by: azaozz
Milestone: 4.6 Priority: high
Severity: normal Version: 4.6
Component: TinyMCE Keywords: has-patch needs-testing needs-refresh
Focuses: Cc:
PR Number:

Description

After switching to the TinyMCE API for non-editable, the gallery previews in wpView are not working properly in IE and iOS. The images in them can be selected and are editable.

Attachments (2)

37427.patch (2.1 KB) - added by azaozz 3 years ago.
37427.2.patch (923.3 KB) - added by azaozz 3 years ago.

Download all attachments as: .zip

Change History (11)

#1 @azaozz
3 years ago

In IE this is caused by triggering the so called "control selection" that wraps the element in a thick border from diagonal lines. Then the actual wpview is not selected and the content is editable.

In iOS Safari the wpview is not selected by tapping on it either. That also makes individual images selectable and editable.

Reported upstream.

@azaozz
3 years ago

#2 @azaozz
3 years ago

  • Keywords has-patch needs-testing added

37427.patch fixes the regressions here but more testing in IE < 11 and older iOS would be nice.

This ticket was mentioned in Slack in #core-tinymce by azaozz. View the logs.


3 years ago

#4 @azaozz
3 years ago

This was fixed upstream in https://github.com/tinymce/tinymce/commit/8512b1cb22c145ca5c8894a333d696f9af806980 and https://github.com/tinymce/tinymce/commit/fa2b83569475b54e75f0c4458a0313fc3d9b331b, thanks @spocke!

We can update TinyMCE to the current dev. version to get these fixes.

@azaozz
3 years ago

#5 @azaozz
3 years ago

In 37427.2.patch: update TinyMCE to the current dev. version as of Jul 21, 2016 (2e7c659870afdca08ca9839c3966e379d2c0d50b). The patch also includes a fix for the wpeditimage plugin for the part where it makes images on iOS selectable on touch.

Last edited 3 years ago by azaozz (previous) (diff)

This ticket was mentioned in Slack in #core-editor by ocean90. View the logs.


3 years ago

#7 @ocean90
3 years ago

  • Keywords needs-refresh added

Looks like TinyMCE 4.4.1 has been released: https://github.com/tinymce/tinymce/compare/4.4.0...4.4.1

#8 @azaozz
3 years ago

In 38155:

TinyMCE: upgrade to 4.4.1, changelog: https://www.tinymce.com/docs/changelog/#version441-july262016.

See #37427.
Fixes #37476.

#9 @azaozz
3 years ago

  • Owner set to azaozz
  • Resolution set to fixed
  • Status changed from new to closed

In 38156:

TinyMCE: fix selecting an image on touch in iOS Safari for TinyMCE 4.4.1.

Fixes #37427.

Note: See TracTickets for help on using tickets.