Make WordPress Core

Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#37430 closed enhancement (fixed)

Add Plugins: Improve the error messages displaying

Reported by: afercia's profile afercia Owned by: tinkerbelly's profile tinkerbelly
Milestone: 4.9 Priority: normal
Severity: normal Version: 4.0
Component: Plugins Keywords: good-first-bug 2nd-opinion has-patch
Focuses: ui Cc:

Description

Minor visual improvements: in the Add Plugins screen, some error messages could use some love. For example, some messages can be very long: setting a max-width and increasing a bit the line-height could help. Also, on the responsive view, maybe the messages should not be displayed in the middle of the page but moved to the top.

https://cldup.com/y_aJ3wOFF6.png

For comparison, this is how the same message gets displayed in the Themes screens, so maybe worth considering also introducing a bit of consistency:

https://cldup.com/ZaBx-VyufE.png

Attachments (10)

patch.diff (1.0 KB) - added by tinkerbelly 8 years ago.
Patch to improve error messaging on plugins page
Screen Shot 2016-07-24 at 15.23.46.png (98.8 KB) - added by tinkerbelly 8 years ago.
"No plugins found" error message.
Screen Shot 2016-07-24 at 15.55.04.png (136.2 KB) - added by tinkerbelly 8 years ago.
Error with patch applied
37430.patch (1.1 KB) - added by juhise 8 years ago.
Patch
37430.2.patch (1.1 KB) - added by juhise 8 years ago.
Patch
37430.3.patch (1.1 KB) - added by Ankit K Gupta 8 years ago.
37430.4.patch (2.6 KB) - added by m1tk00 7 years ago.
Changed the error messages with the Wordpress messages bar.
37430.diff (3.2 KB) - added by swissspidy 7 years ago.
37430.5.diff (3.2 KB) - added by mrahmadawais 7 years ago.
FIX: Consistent Lingo and Button Case
37430.6.diff (5.3 KB) - added by danieltj 7 years ago.
Fixed grammar issue with 'try again' text

Download all attachments as: .zip

Change History (32)

#1 @swissspidy
8 years ago

  • Milestone set to 4.6
  • Version set to trunk

#2 @ocean90
8 years ago

  • Milestone changed from 4.6 to Future Release
  • Summary changed from :Shiny updates improve the error messages displaying to Add Plugins: Improve the error messages displaying
  • Type changed from defect (bug) to enhancement
  • Version changed from trunk to 4.0

The current design exists since 4.0. I agree that it should be improved, but it's not a regression.

@tinkerbelly
8 years ago

Patch to improve error messaging on plugins page

@tinkerbelly
8 years ago

"No plugins found" error message.

@tinkerbelly
8 years ago

Error with patch applied

#3 @tinkerbelly
8 years ago

I tried my hand at a patch here: https://core.trac.wordpress.org/attachment/ticket/37430/patch.diff

It looks as though this error had been using the "no-plugins-results" CSS class, which then styled it the same way as that error message.

Screen Shot 2016-07-24 at 15.23.46.png

Using a standard error class seems more sensible in this case. Here's what the error message looks like with the patch applied:

Screen Shot 2016-07-24 at 15.55.04.png

I'm not certain the "try again" link is required here—it's not used on the same error on the themes page, and it would make sense to keep it consistent. It just refreshes the page; not sure how useful users find it.

Last edited 8 years ago by SergeyBiryukov (previous) (diff)

#4 @juhise
8 years ago

  • Keywords 2nd-opinion added

In my opinion 'Try Again' should look like button not link. It is useful for users as this error is unexpected so user should have the feature to Try Again.

@juhise
8 years ago

Patch

@juhise
8 years ago

Patch

#5 @Ankit K Gupta
8 years ago

This error message appears when something wrong with server configuration and network connectivity as well.
In this case, Try again button would be helpful on theme-install.php same as plugin-install.php.

Adding patch for theme page Try again button.

#6 @Ankit K Gupta
8 years ago

  • Keywords has-patch added; needs-patch removed

#7 @Ankit K Gupta
8 years ago

Can we consider this ticket for 4.8 ?
Thanks!

#8 @swissspidy
8 years ago

  • Keywords needs-patch added; has-patch removed

37430.3.patch is for theme-install.php, not the plugin installer as the ticket suggests.

As for the implementation: a button should be a button, not a link with href="#". See https://make.wordpress.org/core/handbook/best-practices/coding-standards/accessibility-coding-standards/

Since we have ajax search already on the plugin install screen — can we do the reloading without a full page refresh?

@m1tk00
7 years ago

Changed the error messages with the Wordpress messages bar.

@swissspidy
7 years ago

#9 @swissspidy
7 years ago

  • Keywords has-patch added; needs-patch removed

@m1tk00 Finally got around to review your patch as requested. Sorry for the delay!

Instead of moving around <hr class="wp-header-end">, <div class="inline error"> can be used so the notice doesn't get relocated underneath the page title. I fixed this in 37430.diff and made a few optimizations here and there to further unify the error message.


Plugin error message:

https://cldup.com/MetCCm-Da1.png

Theme error message:

https://cldup.com/yiYyebmOlC.png

No plugin found:

https://cldup.com/Ze4QLM8j6q.png

No theme found:

https://cldup.com/4meq64u6Bn.png

#10 @DrewAPicture
7 years ago

  • Owner set to tinkerbelly
  • Status changed from new to assigned

Assigning ownership to mark the good-first-bug as "claimed".

This ticket was mentioned in Slack in #design by sarahsemark. View the logs.


7 years ago

#12 @tinkerbelly
7 years ago

This looks to be best solved by https://core.trac.wordpress.org/attachment/ticket/37430/37430.diff above; feel free to prompt me if there's any further action on my part needed here. :)

#13 @SergeyBiryukov
7 years ago

  • Milestone changed from Future Release to 4.9

@mrahmadawais
7 years ago

FIX: Consistent Lingo and Button Case

#14 @mrahmadawais
7 years ago

I went ahead and add consistent lingo for themes and plugins as well as the buttons in ref with other buttons.

https://i.imgur.com/YXAnIl1.png

https://i.imgur.com/h6cg14T.png

https://i.imgur.com/d0mDdgH.png

Looking forward!

This ticket was mentioned in Slack in #core by jeffpaul. View the logs.


7 years ago

@danieltj
7 years ago

Fixed grammar issue with 'try again' text

#16 @danieltj
7 years ago

In patch 37430.6.diff​...

On top of the patch by @swissspidy and @mrahmadawais - I've fixed a grammar issue.

Try a different search. doesn't make a lot of sense so I've changed it to Try a different search query. instead.

#17 @swissspidy
7 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 41608:

Plugins: Improve error messages on plugins screen.

This unifies the layout and wording of error messages on both the plugins screen and the themes screen.

Props tinkerbelly, juhise, Ankit K Gupta, m1tk00, swissspidy, mrahmadawais, danieltj.
Fixes #37430.

#18 @swissspidy
7 years ago

In 41609:

Plugins: Fix version number in docblock after [41608].

Props ocean90.
See #37430.

#19 @afercia
7 years ago

Please see follow up on #42231

#20 @afercia
7 years ago

In 41878:

Administration: Improve consistency of the "not found" strings.

Partially reverts [41608] restoring the original strings without the word query.

See #37430.
Fixes #42231.

#21 @SergeyBiryukov
7 years ago

In 41915:

Plugins: After [41608], make the markup in WP_Plugin_Install_List_Table::no_items() a bit more readable.

See #37430.

#22 @SergeyBiryukov
7 years ago

In 41916:

Plugins: Revert unintended change from [41915].

See #37430.

Note: See TracTickets for help on using tickets.