WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#37467 closed defect (bug) (fixed)

The same identifiers for all external images at the page ID="__wp-temp-img-id"

Reported by: fomenkoandrey Owned by: azaozz
Milestone: 4.7 Priority: normal
Severity: normal Version: 4.5.3
Component: TinyMCE Keywords: has-patch
Focuses: Cc:

Description (last modified by SergeyBiryukov)

for all external images inserted into the text without any additional classes and alignments present attribute ID, equal __wp-temp-img-id

http://savepic.net/8264884.jpg

IDs must be different at one page.

https://wordpress.org/support/topic/the-same-identifiers-for-all-external-images-at-the-page-id_wp-temp-img-id?replies=3

Attachments (1)

37467.patch (1.1 KB) - added by azaozz 3 years ago.

Download all attachments as: .zip

Change History (8)

#1 @SergeyBiryukov
3 years ago

  • Description modified (diff)

This ticket was mentioned in Slack in #core-editor by azaozz. View the logs.


3 years ago

@azaozz
3 years ago

#3 @azaozz
3 years ago

  • Milestone changed from Awaiting Review to 4.7

Confirmed. Happens when using the TinyMCE default image dialog. We use that dialog as fall-back when the media modal is not loaded.

37467.patch fixes this. It also will remove erroneous IDs from images when editing old posts.

#4 @fomenkoandrey
3 years ago

look like patch works for me.
open post on edit, save - no more temp-id.
insert image - no temp id.
thank U.
i applied the patch to plugin.min.js

will it be applied to the next WP update?

#5 @Presskopp
3 years ago

  • Keywords has-patch added

#6 @azaozz
3 years ago

  • Owner set to azaozz
  • Resolution set to fixed
  • Status changed from new to closed

In 38328:

TinyMCE: make sure the temporary id is removed when using the default image dialog and inserting an external image.

Props fomenkoandrey for reporting and testing.
Fixes #37467.

#7 @fomenkoandrey
3 years ago

I have already created some posts, there is no more temporary ids.
thank U.

Note: See TracTickets for help on using tickets.