Make WordPress Core

Opened 17 years ago

Closed 17 years ago

#3748 closed defect (bug) (worksforme)

"View Post" link links to wrong post when publishing a draft

Reported by: hasaki's profile hasaki Owned by:
Milestone: Priority: low
Severity: normal Version: 2.1
Component: Administration Keywords: "view post", draft
Focuses: Cc:

Description

Using the release version of WP 2.1:

Create a new post (1), save it as a draft.
Create a new post (2), publish it.
Go back to the write page, edit the draft (1) then publish it.

Observe:
The "Post saved. View post »" link will point to post 2.

Expected:
The "Post saved. View post »" link should point to post 1.

Change History (4)

#1 @foolswisdom
17 years ago

  • Milestone changed from 2.3 to 2.2

#2 @foolswisdom
17 years ago

  • Milestone changed from 2.2 to 2.3

#3 @johnbillion
17 years ago

Confirming bug still occurs at r5111. It only occurs if, when publishing the posts, you check the 'Published' checkbox and then click the 'Save' button, ie. don't just press the 'Publish' button.

More detailed steps to reproduce:

  1. Write a new post.
  2. Make sure the 'Draft' checkbox is checked under 'Post Status' and click the 'Save' button.
  3. Write a new post (either by immediately starting a new one on that screen or by clicking the 'Write Post' tab again).
  4. Make sure the 'Published' checkbox is checked and click the 'Save' button.
  5. Click on the link to the first draft post to edit it.
  6. Check the 'Published' checkbox under 'Post Status' and then click the 'Save' button.
  7. Note that the 'View post »' link which appears incorrectly points to the second post you wrote and not the first.

#4 @rob1n
17 years ago

  • Milestone 2.3 deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Works for me at r5307. Both in /branches/2.2 and /trunk.

Note: See TracTickets for help on using tickets.