WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 6 years ago

#3751 closed defect (bug) (invalid)

Wrong menu in added Admin panel

Reported by: takayukister Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.1
Component: Administration Keywords:
Focuses: Cc:

Description

When you add two or more submenus on Admin panel by a plugin, say "Page One" on "Write" menu and "Page Two" on "Manage" menu, the menu of the Page Two incorrectly shows "Write - Page One".

This behavior can be easily reproduced by using attached test plugin.

It seems that this is caused in get_admin_page_parent() in wp-admin/admin-functions.php. I made an ad hoc patch and it works for me.

Ticket #1447 also mentioned this, mainly about get_admin_page_title() though.

Attachments (2)

menu-test.php (803 bytes) - added by takayukister 8 years ago.
The problem can be reproduced by this plugin.
admin-functions.php.diff (881 bytes) - added by takayukister 8 years ago.
Ad hoc patch.

Download all attachments as: .zip

Change History (7)

@takayukister8 years ago

The problem can be reproduced by this plugin.

@takayukister8 years ago

Ad hoc patch.

comment:1 @foolswisdom8 years ago

  • Milestone changed from 2.3 to 2.2

comment:2 @Nazgul8 years ago

  • Keywords has-patch added; menu submenu admin plugin removed

comment:3 @foolswisdom8 years ago

  • Milestone changed from 2.2 to 2.3

comment:4 @markjaquith7 years ago

  • Milestone changed from 2.3 to 2.4 (next)

All in favor of completely redoing our crazy menu system so that it makes sense?

(Aye)

comment:5 @mrmist6 years ago

  • Keywords has-patch removed
  • Milestone 2.9 deleted
  • Resolution set to invalid
  • Status changed from new to closed

Flushing this one since the 2.7 UI redesign.

Re-open if it still presents a problem.

Note: See TracTickets for help on using tickets.