WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 months ago

Last modified 3 months ago

#37532 closed defect (bug) (worksforme)

Cannot delete posts under a common tag

Reported by: movealongpeople Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Posts, Post Types Keywords:
Focuses: administration Cc:
PR Number:

Description

Two bugs both related to deleting posts under a common tag;

When inside: http://movealongpeople.com/wp-admin/edit.php?tag=daily-mail&ids=144891

Trying to delete posts from a common tag;

I get this error while deleting a single post when clicking the 'move to trash' link;

Warning: Illegal offset type in /homepages/45/d514505520/htdocs/clickandbuilds/MoveAlongPeople/wp-admin/edit.php on line 317

If I select all the posts on the page and try to move to trash using the bulk items actions it simply fails completely and give me a page that says 'illegal post type'.

So, there is no easy way to delete out thousands of posts that all contain a common tag. Instead I have to manually move every post to the trash. All 2700 posts.

Can we get a proper way to manage thousands of posts already in wordpress?

Thank you.

Sincerely,

MoveAlongPeople

Change History (3)

#1 @SergeyBiryukov
3 years ago

  • Summary changed from Bug report to Cannot delete posts under a common tag

#2 @desrosj
3 months ago

  • Resolution set to worksforme
  • Status changed from new to closed

Hi @movealongpeople,

Welcome to Trac! My apologies that it took so long to receive a response.

I have been trying to reproduce the issue you described, but I am always able to delete all of the posts on the page with the bulk actions menu.

It's likely that this was either fixed in another ticket, or this was happening because of a conflict with a plugin or theme that was active (I don't recommend the ids query parameter as one WordPress Core uses). But, if you are still able to reproduce this with the latest version of WordPress (currently 5.2.4), feel free to reopen and add more details to reproduce.

#3 @desrosj
3 months ago

  • Version 4.5.3 deleted
Note: See TracTickets for help on using tickets.