WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#37555 closed defect (bug) (duplicate)

A post with a long title goes out of bounds

Reported by: vimukthiperera Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.5.3
Component: Administration Keywords: has-patch
Focuses: ui Cc:

Description

When creating a post with a very long title, the activity in the dashboard goes out of order.

Attachments (2)

Screen Shot 2016-08-03 at 11.05.20 PM.png (51.4 KB) - added by vimukthiperera 3 years ago.
37555-01.diff (651 bytes) - added by Jonnyauk 3 years ago.
Fixes bug with long titles in recent activity. Rathe than create a new CSS rules, I think I've used the most logical existing WP admin CSS class.

Download all attachments as: .zip

Change History (8)

#1 @SergeyBiryukov
3 years ago

  • Component changed from General to Administration
  • Focuses accessibility removed

@Jonnyauk
3 years ago

Fixes bug with long titles in recent activity. Rathe than create a new CSS rules, I think I've used the most logical existing WP admin CSS class.

#2 @Jonnyauk
3 years ago

  • Keywords has-patch added

#3 @Presskopp
3 years ago

I don't think your solution is fitting perfectly, while being elegant. After all it's just using word-wrap: break-word; to solve this issue. But the class name is not really at place. And in the meantime we have a nice little collection of things going out of bounds:

A post with a long title goes out of bounds
#37555

Username text overflows in error message box on login screen.
#37617

long page title issue in drop down list setting>reading page
#37582

text overflows, if it has no hyphens on media upload page.
#37581

...?

Until now WordPress uses only a few instances of word-wrap: break-word; and text-overflow: ellipsis;

My conclusion is to add a new class or two, combining these cases system-wide.

There also seems to be a nice javascript-code helping us, if we wanted that.
http://dotdotdot.frebsite.nl/

I leave the housekeeping to the inner circle of coders now… :)

Last edited 3 years ago by Presskopp (previous) (diff)

#4 @Jonnyauk
3 years ago

@Presskopp - I understand your reasoning for challenging this, and would also wonder if a new common CSS rule should be introduced - but I was trying to avoid doing this as there is a rule that's perfectly acceptable already in the admin CSS.

-1 for Javascript to achieve this, although an interesting idea I feel that it's overkill personally.

#5 @Presskopp
3 years ago

related: #37176, #36081

Last edited 3 years ago by Presskopp (previous) (diff)

#6 @SergeyBiryukov
3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #36081.

Note: See TracTickets for help on using tickets.