WordPress.org

Make WordPress Core

#37573 closed defect (bug) (fixed)

Edit Tag page after click "Update"

Reported by: janbien Owned by: ocean90
Milestone: 4.7 Priority: normal
Severity: normal Version:
Component: Taxonomy Keywords: has-patch
Focuses: administration Cc:

Description

If I go to WP admin page "Edit Tag" from frontend (click on wpadminbar), this is URL:
www.example.cz/wp-admin/term.php?taxonomy=post_tag&tag_ID=2&post_type=post

After I click on "Update" button, I am redirected to page "Tags" ... on this url:
www.example.cz/wp-admin/edit-tags.php?taxonomy=post_tag

I think this is bug. In older WP version, I stayed (after click "Update") on "Edit Tag" page.

Attachments (1)

37573.patch (607 bytes) - added by ocean90 14 months ago.

Download all attachments as: .zip

Change History (5)

#1 @ocean90
16 months ago

  • Component changed from Administration to Taxonomy
  • Focuses administration added
  • Version 4.5.3 deleted

Hello @janbien, welcome to our Trac!

Thanks for your report, I could reproduce the same behaviour on a 3.7 install. A similar behaviour was recently fixed in 4.4 via [34202] for when you click Edit in the term table list.

@ocean90
14 months ago

#2 @ocean90
14 months ago

  • Keywords has-patch added
  • Milestone changed from Awaiting Review to 4.7

I couldn't reproduce the redirect but I now get a "← Back to Tags" that links to itself.

Steps to reproduce:

  • Go to /wp-admin/edit-tags.php?taxonomy=post_tag
  • Click on a View link of a tag
  • Click on the Edit Tag link in the toolbar
  • Click the Update button

Expected: An update message.
Actual: An update message with a "← Back to Tags" link.

37573.patch removes the wp_get_referer () part that was introduced in [34202].

@swissspidy Since you introduced term.php, how does 37573.patch look to you?

Semi-related: #38194

#3 @swissspidy
14 months ago

Without the patch applied, when I follow the instructions I get indeed redirected to the list table after saving the term. No admin notice. When not going the front end route via the toolbar, everything works fine and there's no redirect.

With the patch, I get redirected as well, but now with an admin notice.

With the patch from #38194 applied too, I don't get redirected but the admin notice is now bold.

#4 @ocean90
14 months ago

  • Owner set to ocean90
  • Resolution set to fixed
  • Status changed from new to closed

In 38753:

Taxonomy: On wp-admin/term.php, don't show a 'Back to' link which links to the current page.

Fixes #37573.

Note: See TracTickets for help on using tickets.