WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#3758 closed defect (bug) (invalid)

RSS Feed contains unexpected characters

Reported by: tacker Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.2
Component: General Keywords: rss
Focuses: Cc:

Description

The feed for my blog (r4871) contains a number at the beginning

2356
<?xml version="1.0" encoding="UTF-8"?>
<!-- generator="wordpress/2.2-bleeding" -->
<rss version="2.0"
    xmlns:content="http://purl.org/rss/1.0/modules/content/"
    xmlns:wfw="http://wellformedweb.org/CommentAPI/"
    xmlns:dc="http://purl.org/dc/elements/1.1/"
    >
<channel>

and at the end

                </item>
        </channel>
</rss>

0

The category feed is also affected:

1f65
<?xml version="1.0" encoding="UTF-8"?>
<!-- generator="wordpress/2.2-bleeding" -->

The comment feeds are not affected.

I have deactivated all plugins, but the error persists.

Attachments (1)

feed.xml (18.8 KB) - added by tacker 7 years ago.
defective feed

Download all attachments as: .zip

Change History (12)

comment:1 tacker7 years ago

  • Summary changed from RSS Feed contains characters at beginning and end to RSS Feed contains unexpected characters at beginning and end

comment:2 follow-up: JeremyVisser7 years ago

You wouldn't happen to have any SVN conflicts anywhere, would you?

comment:3 foolswisdom7 years ago

  • Milestone 2.3 deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Closing WORKSFORME
I have tested a number of feeds after updating them to SVN r4871.

JeremyVisser provides a great tip! I would start by searching for those numbers in your files to find out the cause, but in the end I would suggest uploading clean files.

comment:4 in reply to: ↑ 2 tacker7 years ago

Replying to JeremyVisser:

You wouldn't happen to have any SVN conflicts anywhere, would you?

No, svn status is clean.
Searching for the numbers didn't help.

I have other blogs which work, too.

I'll try a new install with this db.

comment:5 tacker7 years ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened
  • Summary changed from RSS Feed contains unexpected characters at beginning and end to RSS Feed contains unexpected characters

I am reopening this because I have setup a clean wordpress on two hosts and the error persists.

What I did:

  1. svn co http://svn.automattic.com/wordpress/trunk
  2. Installed my blogs mysql dump with changed urls

The error is still reproduceable on these two setups:

  1. http://wp-test.clyre.net/feed/
  2. http://m.tacker.org/blog2/feed/

I think this must have something to do with output buffering as the characters also appear inside the feed (see attached output) and there are no charactes in small feeds like http://wp-test.clyre.net/category/digitales/flash/feed/ .

tacker7 years ago

defective feed

comment:6 tacker7 years ago

Characters also appear inside the feed: see line 103 of attached feed.xml

comment:7 foolswisdom7 years ago

  • Milestone set to 2.2

comment:8 link927 years ago

This is likely caused by the client trying to use HTTP/1.0 while the server trying to use HTTP/1.1

comment:9 rob1n7 years ago

@tack: neither of the feeds you listed had the numbers, as far as I could find... Is this through a browser? I'm using Camino and it's fine.

comment:10 tacker7 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed

Ok. My bad.

The PHP docu clearly states that the file wrappers for http

Allows read-only access to files/resources via HTTP 1.0, using the HTTP GET method.

Thank you very much for your efford.

comment:11 foolswisdom7 years ago

  • Milestone 2.2 deleted
Note: See TracTickets for help on using tickets.