WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 3 weeks ago

#37582 closed defect (bug) (invalid)

long page title issue in drop down list setting>reading page

Reported by: gk.loveweb Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.5.3
Component: Administration Keywords: has-screenshots needs-patch
Focuses: ui, administration Cc:

Description

it breaks the limit of dropdown select box in Settings > Reading Settings page, if there is long page title .

Attachments (3)

reading setting.png (47.3 KB) - added by gk.loveweb 4 years ago.
ellipsis.png (40.2 KB) - added by Presskopp 4 years ago.
fixed-issue.png (224.7 KB) - added by desrosj 3 weeks ago.

Download all attachments as: .zip

Change History (7)

#1 @gk.loveweb
4 years ago

  • Keywords has-screenshots needs-patch added

@Presskopp
4 years ago

#2 @Presskopp
4 years ago

This can be handled with the following code:

select {
    width: 100%;
    white-space: nowrap;
    overflow: hidden;
    text-overflow: ellipsis;
}

Not sure where/how to implement, would this be limited to select ?

@desrosj
3 weeks ago

#4 @desrosj
3 weeks ago

  • Component changed from General to Administration
  • Resolution set to invalid
  • Status changed from new to closed

It looks like in the latest version of WP (5.5 at the time of this comment), a really long page title will cause a wide dropdown menu, but it's limited to the width of the window and is abbreviated with an ellipsis. The select element is also limited with a max-width: 25rem.

I'm going to close this one out because I can't reproduce the original issue. If someone is still able to reproduce, feel free to reopen this with more details to reproduce.

Note: See TracTickets for help on using tickets.