WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#37601 closed defect (bug) (invalid)

Cursor is moved mid-typing in new editor on Mac Safari

Reported by: maurymarkowitz Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Editor Keywords:
Focuses: Cc:

Description

I use Mac Safari as my primary editor. When editing in the "new" editor I find you cannot select text and then type to replace it. The first character appears as expected, but any further typing is placed at the end of the paragraph. This is very frustrating!

In the attached images I have selected the word "adding" in order to replace it with the word "finding". As you can see, when I began typing it correctly removed the original text and began inserting my new typing, but after the "f" was entered, it moved the cursor to the end of the paragraph and inserted all further text there.

Attachments (2)

Screen Shot 2016-08-08 at 11.28.14 AM.png (21.4 KB) - added by maurymarkowitz 4 years ago.
Screen Shot 2016-08-08 at 11.28.20 AM.png (18.1 KB) - added by maurymarkowitz 4 years ago.

Download all attachments as: .zip

Change History (7)

#1 @azaozz
4 years ago

  • Focuses ui removed
  • Keywords reporter-feedback added

Testing in Safari 9.1.2(10601.7.7) cannot reproduce this. Selecting some text then typing replaces the text properly. What happens when you press Enter instead of typing. What about backspace? All of these behave as expected here.

Think it's worth it confirming this with all plugins disabled and one of the default themes.

#2 @maurymarkowitz
4 years ago

Pressing return instead of typing works fine.
Pressing backspace also works.
The problem seems to occur only with letters and digits - I assume all printable characters.

I am also on Version 9.1.2 (11601.7.7). I have AdBlock enabled and Grammarly... wait, it's a Grammarly problem. Disabling it seems to have fixed it. I seem to recall seeing this before I installed Grammarly so it might be just a change in Safari's settings that "fixed" it, I will experiment further.

If it is Grammarly causing the problem, any ideas why? I'm not much of an expert on JS editors...

#3 @ocean90
4 years ago

Hello @maurymarkowitz, may I ask which WP version you're using? Are you testing the release candidate of WordPress 4.6?

#4 @maurymarkowitz
4 years ago

I am using whatever version is current on wordpress.com. One of my blogs is at https://matter2energy.wordpress.com

#5 @ocean90
4 years ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed
  • Version trunk deleted

This Trac is used for enhancements and bug reporting for the WordPress core software. For issues with wordpress.com please use their support forums at https://en.support.wordpress.com/.

Note: See TracTickets for help on using tickets.