WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#37676 closed defect (bug) (duplicate)

Links disappear when saving

Reported by: Lindstromer Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.5.3
Component: Editor Keywords: needs-patch
Focuses: javascript Cc:

Description

When inserting links using the new inlinke link tool in the wysiwyg editor you loose the link upon saving. The link is lost if you don't link an existing word(see video) but seems to work if it's an existing word that's being linked.

Attachments (1)

20160816_links_disappear_480p.mov (6.2 MB) - added by Lindstromer 4 years ago.
Steps to reproduce the bug

Change History (3)

@Lindstromer
4 years ago

Steps to reproduce the bug

#1 @swissspidy
4 years ago

  • Component changed from TinyMCE to Editor
  • Focuses javascript added; ui accessibility administration removed
  • Keywords needs-patch added

Thanks for the video @Lindstromer!

I can confirm this in 4.5 and trunk, but only when switching to the "extended" link modal. Also happens when simply switching to the text editor or vice-versa (instead of hitting publish)

#2 @azaozz
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Looks like a duplicate of #36683.

Note: See TracTickets for help on using tickets.