WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#37725 closed defect (bug) (duplicate)

Emails not sending after 4.6 update

Reported by: mindysvas Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.6
Component: Mail Keywords:
Focuses: Cc:

Description

I have tried this on different websites and on different webhosts. The password reset works up until the WordPress core update. Then if I go to reset a password I get this message:
---The email could not be sent. Possible reason: your host may have disabled the mail() function.---

Change History (6)

This ticket was mentioned in Slack in #core by swissspidy. View the logs.


4 years ago

#2 follow-up: @MattyRob
4 years ago

  • Keywords reporter-feedback added

@mindysvas

I've just tested on a live 4.6 installation, using core user functions (i.e. no user / membership plugins) and using the lost password link on the wp-login.php page reports success - tells me to check my inbox for reset link.

#3 @swissspidy
4 years ago

  • Component changed from General to Mail
  • Summary changed from lost password function is not working to Emails not sending after 4.6 update

Hey there,

Thanks for creating this ticket and welcome to WordPress Trac!

We usually suggest people to ask for help in the support forums first until it's clearly recognized as a bug in WordPress. However, as there were a few more reports about broken emails after the update to WordPress 4.6, I'll leave this ticket open to keep track of things.

The related change in core is probably [38058].

To get things started, what's the domain & name of your site?

#4 in reply to: ↑ 2 @mindysvas
4 years ago

@MattyRob
Do you mind sharing what host you are using? I tried sites on Siteground and Bluehost with same issue.
Thanks.

Replying to MattyRob:

@mindysvas

I've just tested on a live 4.6 installation, using core user functions (i.e. no user / membership plugins) and using the lost password link on the wp-login.php page reports success - tells me to check my inbox for reset link.

#5 @MattyRob
4 years ago

@mindysvas

I use a smaller provider called BroadBand Cloud Solutions.

#6 @swissspidy
4 years ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

I'm closing this in favour of #37736, which already has a patch that aims to fix the problem.

Note: See TracTickets for help on using tickets.