WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#37737 closed defect (bug) (duplicate)

Wordpress & Phpmailer : data not all cleared

Reported by: danygold Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.5.3
Component: Mail Keywords:
Focuses: administration Cc:

Description

When sending several emails successive, not all data are cleared from phpmailer.
In my case, I'm sending two emails :

  • One first email validation in HTML (with text and Html as altbody)
  • One second email with some raw data, and custom content-type.

The second email keep the variable "AltBody" from the first email, so wp_mail consider it as a multi part email. And as so, wp_mail() change the content-type from my custom kind to "multipart".

It comes from the re-use of global $phpmailer, instead of create a new phpmailer.
Phpmailer class needs a better clear of all previous variables.

Change History (2)

#1 @stephenharris
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #33972.

#2 @stephenharris
4 years ago

Thanks for reporting this @danygold. This issue is being tracked in #33972.

Note: See TracTickets for help on using tickets.