WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#37753 closed defect (bug) (duplicate)

The Edit button on a gallery does nothing unless you first click on the gallery.

Reported by: efco Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.6
Component: TinyMCE Keywords: needs-patch
Focuses: Cc:

Description

The Edit button on galleries does nothing when clicked unless you first click on the gallery, and bring it into focus (blue highlighted border).

Steps to reproduce:

  1. Edit a page containing a gallery.
  2. Without clicking anything else on the page, hover over and click the gallery edit button.
  3. Nothing happens.
  4. Click the gallery itself, bringing it into focus.
  5. Click the gallery edit button.
  6. Gallery edit window opens as intended.

Change History (7)

#1 @Clorith
4 years ago

  • Component changed from Gallery to Editor

Can replicate this.

When the gallery is the first item in the editor (can't be any text, whitespace, etc. before it) when the page is loaded, the text caret is identified as being at the start of the editor box, making the edit/remove overlay for galleries visible without being a legitimate action at that point.

Does not output the overlay in 4.5.3

Going to chuck this over on the Editor component, as this is caused by the editor behavior, and not the gallery it self I'd say.

#2 @swissspidy
4 years ago

  • Milestone changed from Awaiting Review to 4.7

#3 @jorbin
4 years ago

  • Keywords needs-patch added

#4 @swissspidy
4 years ago

  • Milestone changed from 4.7 to Future Release

Punting because of a lack of traction and beta 1 coming up soon.

#5 @dineshc
4 years ago

#39306 was marked as a duplicate.

#6 @iseulde
4 years ago

  • Component changed from Editor to TinyMCE

#7 @azaozz
4 years ago

  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #38849. Closing this as there is a patch on the other ticket.

Note: See TracTickets for help on using tickets.