WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#37766 closed defect (bug) (duplicate)

WordPress installer has no style.

Reported by: mrapplexz Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Upgrade/Install Keywords: reporter-feedback
Focuses: Cc:
PR Number:

Description

My WordPress installer has no style. How to fix it? http://imgur.com/a/H2VEd
Server configuration: Nginx+Ubuntu 14.04+PHP 7.1.

Attachments (1)

hJOmCSO.png (109.4 KB) - added by SergeyBiryukov 3 years ago.

Download all attachments as: .zip

Change History (11)

#1 @SergeyBiryukov
3 years ago

  • Component changed from General to Upgrade/Install

#2 @johnbillion
3 years ago

  • Keywords reporter-feedback added

Thank for the ticket, @mrapplexz.

This could be an issue with the fastcgi_param configuration in your Nginx setup which means the required environment variables aren't being passed to PHP.

  • What's the value of $_SERVER['HTTP_HOST'] and $_SERVER['SERVER_NAME'] on your server?
  • What happens when you run the WordPress installer? Does your site get installed and work as expected?

#3 @mrapplexz
3 years ago

@johnbillion
$_SERVER['HTTP_HOST'] out - beta.pxsrv.ru
$_SERVER['SERVER_NAME'] out - beta.pxsrv.ru
After installation, site works and has style, but wp-admin and wp-login has no style.

#4 @SergeyBiryukov
3 years ago

Any chance to find out where the http://./install.css URL on the screenshot comes from?

In the source code, it's just ./$file.css, without http://.

#5 @mrapplexz
3 years ago

@SergeyBiryukov in page source (line 8):

<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
	<meta name="viewport" content="width=device-width" />
	<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
	<meta name="robots" content="noindex,nofollow" />
	<title>WordPress &rsaquo; Setup Configuration File</title>
	<link rel='stylesheet' href='http://./install.css?version=4.6' type='text/css' />
</head>
<body class="wp-core-ui">
<p id="logo"><a href="https://wordpress.org/" tabindex="-1">WordPress</a></p>
<h1 class="screen-reader-text">Before getting started</h1>
<p>Welcome to WordPress. Before getting started, we need some information on the database. You will need to know the following items before proceeding.</p>
<ol>
	<li>Database name</li>
	<li>Database username</li>
	<li>Database password</li>
	<li>Database host</li>
	<li>Table prefix (if you want to run more than one WordPress in a single database)</li>
</ol>
<p>We&#8217;re going to use this information to create a <code>wp-config.php</code> file.	<strong>If for any reason this automatic file creation doesn&#8217;t work, don&#8217;t worry. All this does is fill in the database information to a configuration file. You may also simply open <code>wp-config-sample.php</code> in a text editor, fill in your information, and save it as <code>wp-config.php</code>.</strong>
	Need more help? <a href="https://codex.wordpress.org/Editing_wp-config.php">We got it</a>.</p>
<p>In all likelihood, these items were supplied to you by your Web Host. If you don&#8217;t have this information, then you will need to contact them before you can continue. If you&#8217;re all ready&hellip;</p>

<p class="step"><a href="setup-config.php?step=1" class="button button-large">Let&#8217;s go!</a></p>
</body>
</html>

install.css path: wp-admin/css/install.css

#6 @mrapplexz
3 years ago

My nginx site config:

server {
        listen 80 default_server;
        listen [::]:80 default_server ipv6only=on;

        root /var/www/beta;
        index index.php index.html index.htm;

        server_name beta.pxsrv.ru;

        location / {
                # try_files $uri $uri/ =404;
                try_files $uri $uri/ /index.php?q=$uri&$args;
        }

        error_page 404 /404.html;

        error_page 500 502 503 504 /50x.html;
        location = /50x.html {
                root /usr/share/nginx/html;
        }

        include global/php.conf;
}

php.conf:

location ~ \.php$ {
        try_files $uri =404;
        fastcgi_pass unix:/var/run/php/php7.1-fpm.sock;
        fastcgi_index index.php;
        include fastcgi_params;
    }

#7 follow-up: @pothi
3 years ago

It happens only with PHP 7.1.0 beta 3.

Works flawlessly on Ubuntu 16.04, Nginx, PHP 7.0.x, though.

Here's some more info from the install screen...

On top of the install screen...

Warning: Parameter 1 to wp_default_styles() expected to be a reference, value given in path/to/wordpress/wp-includes/plugin.php on line 600

At the very bottom of the install screen...

Warning: Parameter 1 to wp_default_scripts() expected to be a reference, value given in path/to/wordpress/wp-includes/plugin.php on line 600

PHP 7.1.0 is yet in beta. Release schedule can be seen at https://wiki.php.net/todo/php71

#8 in reply to: ↑ 7 ; follow-up: @SergeyBiryukov
3 years ago

Replying to pothi:

It happens only with PHP 7.1.0 beta 3.

Sounds like a duplicate of #37772 then.

#9 in reply to: ↑ 8 @pothi
3 years ago

Replying to SergeyBiryukov:

Replying to pothi:

It happens only with PHP 7.1.0 beta 3.

Sounds like a duplicate of #37772 then.

Indeed. Let's close this or merge this with the other.

I am not familiar with ticket system. I primarily use forums to report similar things. Came across this ticket in slack.

#10 @johnbillion
3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #37772.

Note: See TracTickets for help on using tickets.