WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#3777 closed defect (bug) (worksforme)

Create Post bug, weird formating if linked url has two dashes in a row

Reported by: bobmorris60 Owned by:
Milestone: Priority: low
Severity: normal Version:
Component: Administration Keywords:
Focuses: Cc:

Description

I've found what I think is a weird bug in the editor in WP. Basically, if you create a link in a post, and the url to the link has two dashes in a row, it mangles the post, adding the text after the link to the top of the post as well as under it. Seriously... What's odder, the post looks fine in the editor, but is mangled in the preview window and when it appears on the blog.

This is repeatable in both WordPress.org and WordPress.com. It happened to me in versions previous to 2.1, and took me quite a while to figure out.

An example, this url (note the two dashes) created a mangled post in the editor when creating a link with it.

http://www.dott07.com/blog/index.cfm/2007/2/5/Doors-of-Perception-9--Juice

I then used tinyurl for that url and the post then displayed fine. There's at least one news site (I forget which) where the urls always end with two dashes and I always have to use tinyurl.

Can anyone else duplicate this?

Change History (5)

comment:1 @andy8 years ago

Just tested against trunk with the dott07 link provided above. No problems.

comment:2 @bobmorris608 years ago

Someone else said that too. No clue then... Thx.

Take it off suspected bug list

comment:3 @intoxination8 years ago

I have seen this bug in action on WP2.1. The problem is that it seems to be intermittent. The original poster contacted me regarding this yesterday and I could get it to happen in 2.1. I tried again today and it didn't happen. Seems to be one of those nightmare intermittent problems. This was on IE7.

What happened was when entering that URL, Wordpress stripped out the entire URL and changed the link to http:/// (it added the exta/closing slash).

Today I would mark this as invalid if I didn't see it myself yesterday.

comment:4 @andy8 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

I would love to help you with a fix for this, intoxication, but you have given me no new information to help me reproduce the problem. Reopen if you can provide something.

comment:5 @foolswisdom8 years ago

  • Milestone 2.3 deleted
Note: See TracTickets for help on using tickets.