WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 8 weeks ago

#37804 closed defect (bug) (wontfix)

Can't view other plugin details while updating an active plugin

Reported by: dlh Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Upgrade/Install Keywords:
Focuses: Cc:
PR Number:

Description

Steps to replicate:

  1. Activate an outdated plugin.
  2. From /wp-admin/plugins.php, click "update now" for the plugin.
  3. While the plugin updates, click the "View details" link for another plugin (or "view version [x.y.z] details" for a plugin with an available update).
  4. Instead of the details, you get maintenance mode.

The workflow where I encounter this behavior is, with multiple updates available, to start the upgrade for one plugin and try to read the upgrade notes for the next plugin while the last one finishes.

That said, maintenance mode might be the expected behavior, based on ticket:29820#comment:11.

Change History (4)

#1 @swissspidy
3 years ago

The plugin details modal is basically an iframe loading the information from your site, so yeah a maintenance mode is indeed expected behaviour there.

If we could load the information from dotorg for example, that could be avoided.

#2 @desrosj
7 months ago

  • Keywords reporter-feedback close added

@dlh do you have any interest in attempting a patch for this? I'm inclined to close this out as a wontfix.

#3 @dlh
7 months ago

Probably not, so feel free to shut this one down.

#4 @desrosj
8 weeks ago

  • Keywords reporter-feedback close removed
  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

Closing this out since this is expected behavior.

Note: See TracTickets for help on using tickets.