WordPress.org

Make WordPress Core

Changes between Initial Version and Version 1 of Ticket #37825, comment 4


Ignore:
Timestamp:
09/11/2016 09:22:12 AM (3 years ago)
Author:
flixos90
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #37825, comment 4

    initial v1  
    55
    66Regarding the naming conventions, good point with the `is_multi_taxonomy()` name, your approach is certainly more clear. About the underscore prefix, when was this decided? It feels to me that if we don't do that anymore, the function won't be "marked" as private anymore (although of course it's technically not private anyway). I have always felt like the underscore-prefixed functions would indeed be treated as private so that we could theoretically remove them if they weren't used anymore (as that underscore should discourage plugin/theme developers to use it).
    7 
    8 >
    9 > A couple notes on the patch:
    10 > - `is_multi_taxonomy()` does not feel like the right name for this proposed function. `is_multi_author()` is checking to see whether the site has multiple authors. By extension, `is_multi_taxonomy()` would check to see whether the site has multiple taxonomies. But this is not right. `wp_taxonomy_has_multiple_terms( $taxonomy )` seems more semantically correct.
    11 > - I don't think we need to have the underscore prefix for `_clear_multi_taxonomy_cache()`. We're moving away from this kind of naming convention.
    12 >
    13 >
    14 >
    15 >