WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 2 years ago

#37854 closed feature request (duplicate)

Walker_Nav_Menu_Edit Filters

Reported by: mireillesan Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.6
Component: Menus Keywords:
Focuses: Cc:
PR Number:

Description

Please add additional filters inside Walker_Nav_Menu_Edit, so we can easily add our own fields to the menu item setting.

Right now, if we were to add a simple text/checkbox field, we need to copy this entire Walker ( about 200 lines of code), only to add about 6 lines of additional code for a custom input field. If possible, WordPress should really offer a more efficient solution.

Change History (2)

#1 @welcher
3 years ago

  • Keywords needs-patch added

Thanks for the ticket!

Did you want to try a patch to get things started?

#2 @SergeyBiryukov
2 years ago

  • Keywords needs-patch removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #18584 and #38904.

Note: See TracTickets for help on using tickets.