WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#37902 closed defect (bug) (fixed)

Cancelling password when adding a new user results in error

Reported by: smerriman Owned by: SergeyBiryukov
Milestone: 4.7 Priority: normal
Severity: normal Version: 4.3
Component: Users Keywords:
Focuses: Cc:
PR Number:

Description

1) Go to Users - Add New.
2) Fill in a Username + Email
3) Click Show Password, then click Cancel
4) Click Add New User.

A user won't be created, with the error "ERROR: Please enter a password.", even though the same process works if you skip step 3.

I believe this was caused by [33980], in which case that should have only been applied to editing a user, not creating one.

Change History (2)

#1 @SergeyBiryukov
3 years ago

  • Milestone changed from Awaiting Review to 4.7

#2 @SergeyBiryukov
3 years ago

  • Owner set to SergeyBiryukov
  • Resolution set to fixed
  • Status changed from new to closed

In 38494:

Users: After [33766], don't reset the password when clicking "Show Password" and then "Cancel" on Add New User screen.

Props smerriman for reporting.
Fixes #37902. See #33419.

Note: See TracTickets for help on using tickets.