WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#3791 closed enhancement (fixed)

wp_die() should understand WP_Error objects

Reported by: mdawaffe Owned by:
Milestone: 2.2 Priority: low
Severity: normal Version: 2.1
Component: Administration Keywords: has-patch 2nd-opinion
Focuses: Cc:

Description

Will make issue brought up by #3775 a bit easier.

Attachments (1)

3791.diff (1.2 KB) - added by mdawaffe 7 years ago.

Download all attachments as: .zip

Change History (3)

mdawaffe7 years ago

comment:1 mdawaffe7 years ago

Where the issue is that functions should be sending WP_Error objects up the stack to give the initiator a choice of actions.

comment:2 ryan7 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [4892]) Add WP_Error handling to wp_die(). Props mdawaffe. fixes #3791

Note: See TracTickets for help on using tickets.