WordPress.org

Make WordPress Core

Opened 13 months ago

Last modified 6 months ago

#37925 reopened defect (bug)

permalink not updating after editing slug, on post edit admin page

Reported by: stevepuddick Owned by:
Milestone: Awaiting Review Priority: normal
Severity: normal Version: 4.6
Component: Permalinks Keywords:
Focuses: javascript Cc:

Description

When editing an existing permalink on a post edit page, the link itself does not update until the post is updated (save draft, or update is clicked). However, the text for the permalink is immediately updated. It is expected that the permalink will also be updated to the new value and not just the permalink text. This bug can be recreated as follows:

1) click the 'edit' button on any post edit screen (on any custom post type that supports permalinks)
2) edit the slug to have an alternate value
3) click on the anchor text next to the 'edit' button. This will bring you to a 404 page since that old link is no longer correct

Refer to this screenshot for more info:

http://webrockstar.net/wp-permalink-bug.png

Attachments (1)

Post Edit Permalink Change.png (12.6 KB) - added by lukecavanagh 6 months ago.
Post Edit Permalink Change

Download all attachments as: .zip

Change History (5)

#1 follow-up: @rinkuyadav999
13 months ago

  • Resolution set to wontfix
  • Status changed from new to closed

Link will not update till you press page update button.

#2 in reply to: ↑ 1 @SergeyBiryukov
12 months ago

  • Resolution wontfix deleted
  • Status changed from closed to reopened

Replying to rinkuyadav999:

Link will not update till you press page update button.

That's the issue being reported. It's not necessarily the expected behaviour if it leads to a 404 error.

Related: #35352

#3 @konoknew
6 months ago

Yes Same Problem I am stack.......... Please anyone help me

#4 @lukecavanagh
6 months ago

@stevepuddick

The permalink will not update until a user clicks the Update button on the Edit Post screen. If you click on Permalink then edit, that will allow you to update the slug, then hit OK, but when you click on OK that will not update the permalink.

edit-slug-box
https://core.trac.wordpress.org/browser/tags/4.7/src/wp-admin/edit-form-advanced.php#L593

@lukecavanagh
6 months ago

Post Edit Permalink Change

Note: See TracTickets for help on using tickets.