WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 days ago

#37988 closed defect (bug) (invalid)

Upgrade network: php timeout in wp-admin/network/upgrade.php

Reported by: podpirate Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.6.1
Component: Networks and Sites Keywords: reporter-feedback
Focuses: multisite Cc:

Description

Setup:

  • Pretty slow server running php 5.5 (As a result calling wp-admin/upgrade?step=upgrade_db might take several seconds in average.)
  • PHP max_execution_time is 30 seconds. Value can't be changed by scripts.
  • WP-Multisite with about 400 blogs.

Reproduction:

  • Call wp-admin/network/upgrade.php?action=upgrade
  • Result: Network Upgrade gets stuck at some point, terminating with http error 500

Change History (3)

This ticket was mentioned in Slack in #core-multisite by flixos90. View the logs.


3 years ago

#2 @flixos90
3 years ago

  • Keywords reporter-feedback added

@podpirate Thanks for the ticket. Can you tell us which version of WordPress you're using and if you have any plugins installed? If so, would you mind telling which plugins?

#3 @desrosj
3 days ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Going to close this out due to lack of reporter feedback. @podpirate if you can still reproduce this issue on the current version of WordPress, please reopen with more details.

Note: See TracTickets for help on using tickets.