WordPress.org

Make WordPress Core

Opened 10 years ago

Closed 10 years ago

Last modified 5 weeks ago

#38 closed enhancement (invalid)

More Better Options Regarding Authors

Reported by: trevorturk Owned by: matt
Milestone: Priority: normal
Severity: normal Version:
Component: Administration Keywords:
Focuses: Cc:

Description

I picked up from the support forum that this is fairly easy to do via phpmyadmin, but I think you should be able to delete Authors within the Users admin area.

Also, I think there should be a way to change each post's author - possibly from within the Users admin area.

You might need an option so when you want to delete a user, you have to pick who to assign their posts to - or else default to the Admin.

I had an idea that you could have, in the Users admin area, a set of three drop downs. They would function like "Start Post Number" "End Post Number" and "Author". So you would pick the starting post number and the ending post number (if needed) and it would assign those post(s) to that author.

Change History (7)

comment:2 JasonV10 years ago

You can delete authors from the users area, just reduce their level to 0 then click the red 'X'.

comment:3 anonymousbugger10 years ago

Decrease the author level to 0 and they will be deleted. A little counter-intuitive but it works.

comment:4 anonymousbugger10 years ago

If you do that, what happens to the posts that are assigned to them?

comment:5 matt10 years ago

  • Owner changed from anonymous to matt
  • Resolution changed from 10 to 70
  • Status changed from new to closed

They are deleted. Not a bug. Closing.

comment:7 ircbot5 weeks ago

This ticket was mentioned in IRC in #wordpress-dev by westonruter. View the logs.

Note: See TracTickets for help on using tickets.