WordPress.org

Make WordPress Core

#38001 closed feature request (duplicate)

Theme un/installation hooks like plugins

Reported by: sidati Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Themes Keywords:
Focuses: Cc:

Description

Hi,

register_activation_hook, register_deactivation_hook & register_uninstall_hook are very helpful for plugins but for themes there is no such thing, yes i do know the existence of after_switch_theme & switch_theme but there is no after_delete_theme action and never will be, cause there is no access to theme php files after deactivation.

That is why i suggest to use "the plugin approach" with themes :), what do you think ?

Change History (1)

#1 @swissspidy
22 months ago

  • Focuses template removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version trunk deleted

Duplicate of #14955.

Note: See TracTickets for help on using tickets.