WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 13 months ago

#38014 closed defect (bug) (worksforme)

blank /wp-admin/index.php after upgrade from 4.5.x, missing Save Settings (button) in Settings > General

Reported by: scaturan Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.6
Component: General Keywords:
Focuses: administration Cc:

Description

Platform:

Apache/2.4.23 (FreeBSD)
PHP/5.6.25
mySQL 5.5.51

Like all my WordPress installations over the years, my codebase is unmodified with no plugins present or active. I don't use 3rd party plugins either, just whatever stock theme comes with latest.zip

Also, I perform upgrades manually.

--

Shortly after upgrading from 4.5.x (fresh install, just copied over previous .htaccess and wp-config.php files) - /wp-admin/index.php renders blank. I can login just fine (but get redirected to a blank page), and can also access /wp-admin/edit.php to modify posts or pages without any issues.

a 200 HTTP status code is sent by Apache when I open /wp-admin/index.php

Also, Settings > General > Save Settings (button) is not visible unless language-related code is removed. The same button is visible in all other areas like Writing, Discussion, etc..

On a fresh install of 4.5, I don't see this particular issue, so clearly, there's a code change somewhere.

Please advise, thank you.

Steve

Change History (16)

#1 @dd32
4 years ago

Hi @scaturan and welcome back to Trac.

A blank render of the page, and output halting at the language sections, suggests that you may be hitting a PHP Fatal error during the page load for some reason, or perhaps a permissions error which is being hidden by PHP.

Can you check your PHP error logs for any fatal errors, and/or attempt defining `WP_DEBUG` to see if that'll allow for the error messages to be shown?

#2 @scaturan
4 years ago

I did those two things already (change to php.ini error_reporting options & setting WP_Debug to "true" - but no error messages are being shown.

the Source with /wp-admin/options-general.php is blank after this line.

"<option value='6' >Saturday</option></select></td>
</tr>"

the Source for /wp-admin/index.php is always empty.

Any other options I can explore?

Please advise, thank you!

#3 @dd32
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Unfortunately nothing I can suggest, you'll need to figure out where and why PHP is failing by triple checking your logs. You may wish to attempt to re-apply all the WordPress files to ensure your issue isn't from a partial upgrade (But that should be obvious from PHP logs indicating the fatal error).

If you're using suhosin you may wish to disable that and/or check it's log files, but without further detail here there's nothing we can go on, and nothing to suggest it's a bug within WordPress 4.6 (which is in use by many millions of others already without similar reports).

Trac is not for support, instead we have the Support Forums for helping diagnose site problems.
I'm marking this as invalid, pending information which can be used to actually pinpoint a bug - at which time we can re-open it.

Last edited 4 years ago by dd32 (previous) (diff)

This ticket was mentioned in Slack in #core by celloexpressions. View the logs.


4 years ago

#5 @scaturan
4 years ago

Actually, I had no resolution from the Support Forums for more than 1 week, so I had resorted here. Will keep looking for clues as to why the behavior exists.

#6 @scaturan
4 years ago

alright, looks like I found something:

after removing this line from /wp-admin/options-general.php - the Save Settings button finally appears:
$translations = wp_get_available_translations();

after removing this line from /wp-admin/index.php - Dashboard no longer renders a blank page:
wp_dashboard_setup();

I tested this on a fresh install of 4.6 and another site upgraded from 4.5.x

#7 @scaturan
4 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

Looks like I'm not the only one anymore.

https://wordpress.org/support/topic/blank-wp-adminindexphp/#post-8200490

This is clearly a bug since more than one person is able to reproduce it. Although not a high priority, removal of the two very specific lines points to something that needs to be addressed.

#8 @SergeyBiryukov
4 years ago

  • Milestone set to Awaiting Review

#9 @ocean90
4 years ago

#38153 was marked as a duplicate.

#10 @ocean90
4 years ago

Does someone have a test site with a clean install where the same error exists? I'd like to have a look, please DM me ("ocean90") on Slack.

#11 @scaturan
4 years ago

@ocean90
thank you for considering to look into this issue. I left you a DM on Slack yesterday with all the site/login details. Thank you once more!

#12 @mikeatdatafault
4 years ago

Apparantly its a compatability issue that is resolved in the latest version of PHP (5.6.26) if that helps any

#13 @uheber
4 years ago

Hello together,

I have the same problem as described by scaturan. Installed a fresh WordPress 4.6.1 DE including new database.

Request to /wp-admin/index.php is displayed as blank page. But when I remove the function call wp_dashboard_setup(); (/wp-admin/includes/dashboard.php) then admin content is rendered.

So the problem can be reproduced.

I am using WordPress on FreeBSD 10 with NGinX v1.10.1 and PHP-FPM v5.6.24.

No errors in nginx logs available, WordpressP/PHP debug mode active.

Will try to use the latest PHP version (5.6.27) and let you know, if it helps.

Last edited 4 years ago by uheber (previous) (diff)

#14 @scaturan
4 years ago

the problem still exist on WordPress 4.7-RC1 both under PHP 5.6 and 7.0.13 -- the remedy is the same as I noted earlier.

I also noticed that opening /wp-admin/update-core.php renders a blank page alongside a 500 Internal Server Error response status, but after a browser REFRESH, a 200 response status is sent and the page renders correctly.

#15 @desrosj
13 months ago

  • Focuses administration added
  • Keywords close added

@mikeatdatafault @ocean90 do you recall what the compatibility issue was that resolved this issue, or if there were any more specifics discovered? I have tried, but I am unable to reproduce this issue.

Going to mark this as a close candidate as there are no specific details to reproduce, what the error message actually was, or any new reports.

#16 @ocean90
13 months ago

  • Keywords close removed
  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from reopened to closed

No, but I guess it was OPcache related.

Note: See TracTickets for help on using tickets.