WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#3813 closed defect (bug) (invalid)

Editing text formatting in IE 7 causes "Are you sure you want to navigate away from this page?" dialog

Reported by: novasource Owned by:
Milestone: Priority: high
Severity: major Version: 2.1.2
Component: TinyMCE Keywords:
Focuses: Cc:

Description

Editing text formatting in IE 7 causes "Are you sure you want to navigate away from this page?" dialog. E.g., select a word and hit the B (boldface) button.

Change History (18)

comment:1 novasource7 years ago

  • Milestone changed from 2.3 to 2.1.1

Needs to be fixed immediately.

comment:2 foolswisdom7 years ago

  • Milestone changed from 2.1.1 to 2.1.2

comment:3 novasource7 years ago

  • Resolution set to invalid
  • Status changed from new to closed

After reinstall of WordPress per 3814, I can no longer reproduce.

comment:4 foolswisdom7 years ago

  • Milestone 2.1.2 deleted

comment:5 novasource7 years ago

  • Milestone set to 2.1.2
  • Resolution invalid deleted
  • Status changed from closed to reopened

Sorry, it's happening again. Nothing substantive has changed with my browser or WordPress install since it last worked.

comment:6 rob1n7 years ago

  • Milestone 2.1.3 deleted
  • Resolution set to invalid
  • Status changed from reopened to closed

I can't reproduce.

comment:7 rob1n7 years ago

(That's on 2.1.2, IE 7)

comment:8 rob1n7 years ago

  • Component changed from Administration to TinyMCE

comment:9 rob1n7 years ago

Also, that's in both the TinyMCE editor and the plain text editor.

comment:10 novasource7 years ago

  • Priority changed from normal to high
  • Resolution invalid deleted
  • Status changed from closed to reopened
  • Version changed from 2.1 to 2.1.3

Brand new install of Windows Vista with all patches. The first time I load my blog and log in to edit an article, I get this error when I try to make an unordered list.

Please note that at the same time, I am now experiencing bugs http://trac.wordpress.org/ticket/3821 and http://trac.wordpress.org/ticket/3822. These are Firefox-related editor usability bugs, but they are curiously similar to this.

comment:11 novasource7 years ago

I also notice a script error in IE. IE's script error reporting is abysmal, but here's what it's saying:
Line: 2872
Char: 5089
Error: Object doesn't support this property or method
Code: 0
URL: http://[my site url]/blog/wp-admin/post.php?action=edit&post=259

Cycling through the Previous and Next buttons shows this exact error has been reported numerous times since the prior page load.

comment:12 novasource7 years ago

  • Milestone set to 2.1.3

Adding milestone.

comment:13 novasource7 years ago

  • Milestone changed from 2.1.3 to 2.1.2

Correcting version.

comment:14 novasource7 years ago

  • Milestone changed from 2.1.2 to 2.1.3
  • Version changed from 2.1.3 to 2.1.2

Oops, got milestone and version mixed up.

comment:15 Nazgul7 years ago

  • Milestone changed from 2.1.3 to 2.3

Bumpint the milestone, because of the imminent release of 2.1.3.

comment:16 novasource7 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

I just realized the problem is WPG2 2.01. I disabled it, cleared my cache, and went back to the Write page, and the problem described in this ticket went away. Re-enabling it and clearing my cache again brings back the problem. I'll take this up with the WPG2 guys.

comment:17 rob1n7 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:18 rob1n7 years ago

  • Milestone 2.3 deleted
  • Resolution set to invalid
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.