WordPress.org

Make WordPress Core

#38139 closed enhancement (duplicate)

Theme update through Dashboard

Reported by: rinkuyadav999 Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Themes Keywords:
Focuses: administration Cc:

Description

WordPress do not update theme using Appearance > Theme > Add New.

As we know, a theme can be updated through Dashboard, if it is hosted on w.org.

But what if a user what to update theme using
Appearance > Themes > Add new > Upload theme.
Appearance > Themes > Add new > Upload theme / update theme. (may be we can add this feature).

Suppose we have a theme called xyz v1. and we want to update with xyz v2 by uploading through Dashboard. in this case, we will see error > Parent folder already exit.

I think it should check version of installed and uploaded and if uploaded theme is a valid and updated version, wp should update it.

Right now we can do that only using FTP.

Attachments (1)

update-theme.png (15.9 KB) - added by rinkuyadav999 12 months ago.
Error Screenshot

Download all attachments as: .zip

Change History (2)

@rinkuyadav999
12 months ago

Error Screenshot

#1 @ocean90
12 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version trunk deleted

Duplicate of #9757.

Note: See TracTickets for help on using tickets.