WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#38189 closed feature request (duplicate)

It does not look like you can drag a zip file into plugin upload

Reported by: Shelob9 Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Plugins Keywords:
Focuses: ui Cc:
PR Number:

Description

You can drag a zip file over the file chooser for uploading files and it will use that file. That's great.

But there is no indication that you can do it. The heading "If you have a plugin in a .zip format, you may install it by uploading it here." does not indicate that is possible, nor is there any visual change to indicate its going to work when you hover a file over the file uploader.

The way it works in the media uploader is great, plugin upload screen really should be like that.

Change History (4)

#1 @ChrisWiegman
3 years ago

As the behavior of the upload button is default browser behavior (a file dragged to a "file" form field should populate the field) are you thinking a better indication of this or adding a listener to the form itself to allow the file drop anywhere on the form?

#2 @afercia
3 years ago

  • Type changed from defect (bug) to feature request
  • Version trunk deleted

Plugin (and Theme) zip uploaders don't implement any "drop zone" like in the Media uploader, which is a JavaScript based functionality. In the plugin uploader instead, as also @ChrisWiegman pointed out, it's just a default browser behavior. So if you're suggesting to implement a JS based solution that's perfectly OK but more a feature request than a bug. Not 100% sure but I think there is also a previous ticket asking for the same feature.

#3 @lukecavanagh
3 years ago

@Shelob9

Looks like it might be similar to ticket.

https://core.trac.wordpress.org/ticket/24579

#4 @swissspidy
3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

As pointed out, that's a browser feature and shouldn't need an introduction. I'd rather have a "drag anywhere on the screen" functionality like for media, so I'm closing this as a duplicate of #24579.

Note: See TracTickets for help on using tickets.