WordPress.org

Make WordPress Core

Opened 15 years ago

Closed 13 years ago

#3820 closed defect (bug) (worksforme)

Squid in accelerator mode; Permalink "mod_rewrite" problem.

Reported by: shanefroebel Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.2
Component: General Keywords: reporter-feedback
Focuses: Cc:

Description

Yesterday I installed squid on our main domain, battlestarwiki.org. And our WordPress (Version 2.2), installed at blog.battlestarwiki.org, falls under the domain. When I went to "click" on a link, it brings me back to the "main" index.

http://blog.battlestarwiki.org/2007/02/19/ahoy-matty-i-got-me-a-squid/ is a perfect example. Clicking on the link, does not allow me to view the single post by itself.

We have Mediawiki installed and it works just fine with mod_rewrite.

Thanks for your time. :-)

Change History (12)

#1 @foolswisdom
15 years ago

  • Milestone changed from 2.2 to 2.3
  • Priority changed from high to normal
  • Severity changed from blocker to normal

shanefroebel, thank you for participating in WordPress! As WordPress uses the same or very similar mod write rules as other blogging systems, I would be surprised if the fault is WordPress'.

I don't really understand the nature of these problems, but someone on IRC suggested "try 404 handler. probably PATH_INFO is mangled on your side"

Realistically, if the problem is WordPress' it is unlikely be be resolved unless you are able to isolate the problem further.

#2 @shanefroebel
15 years ago

Expain.. I don't quite understand what you mean to test.

#3 @shanefroebel
15 years ago

Ok.. I've done some digging into the WordPress code itself. When I installed a new version of WordPress on the server, the "URL" for the administration settings "WordPress Address (URL)" and "Blog Address (URL)" came out to be:

http://blog.battlestarwiki.orghttp://blog.battlestarwiki.org/index.php

So this tells me, as Squid reads the installation from Apache, the location paths are not correct when trying to run a rewrite URL. Now squid "acts" as the "processing" point (external IP address) and talks with Apache which is now on 127.0.0.1. So when everything goes through it it changes it's makeup.

Now I looked through the rewrite class, and I can not make heads or tails on how to see how it works. Somewhere in their is where something has to be defined to say "oh, we have squid installed. Goto the right "url/file" location.

I hope that is clear enough.

#4 @markjaquith
15 years ago

There should be no index.php in your Blog Address setting.

#5 follow-up: @shanefroebel
15 years ago

I have had that removed for a while. Doesn't WordPress.com use Squid?

#6 in reply to: ↑ 5 ; follow-up: @foolswisdom
15 years ago

Replying to shanefroebel:

I have had that removed for a while. Doesn't WordPress.com use Squid?

I asked and the answer is no. The answer of what we do use is likely in our job posting page: Debian/Ubuntu, PHP, MySQL, Litespeed, Pound, Wackamole, Spread, Nagios, Munin, Monit, NFS, Postfix, MyDNS.

#7 @shanefroebel
15 years ago

Great :(

#8 in reply to: ↑ 6 @shanefroebel
15 years ago

What file process the "mod_rewrite" requests (i.e. filenames and line numbers) and I could try to work on a fix for us squid needed people.

#9 @shanefroebel
15 years ago

  • Cc shane.froebel@… added

#10 @Nazgul
14 years ago

  • Milestone changed from 2.3 to 2.5

#11 @Nazgul
14 years ago

See also #3686.

#12 @Viper007Bond
13 years ago

  • Keywords reporter-feedback added; squid mod_rewrite removed
  • Milestone 2.9 deleted
  • Resolution set to worksforme
  • Status changed from new to closed

I use Squid as a reverse proxy on http://www.finalgear.com/ with no problems. Since this ticket is over 2 years old and I personally have WordPress working with Squid and Apache with no problems (no idea about the configuration though as I didn't set it up), I'm gonna close it as worksforme. If anyone is still having trouble, please reopen.

Note: See TracTickets for help on using tickets.