WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 8 years ago

#3821 closed defect (bug) (invalid)

Several formatting buttons in editor do not work in Fx 2.0.0.3

Reported by: novasource Owned by:
Milestone: Priority: high
Severity: major Version: 2.1.2
Component: General Keywords:
Focuses: Cc:

Description

I just did a fresh reinstall of WordPress 2.1 per 3814. When editing a post, the following buttons do not work:

  • bold
  • italics
  • strikethrough
  • ul
  • ol

In each case, pressing the button appears to apply the style and then immediately revert it.

Change History (16)

comment:1 @novasource8 years ago

  • Resolution set to invalid
  • Status changed from new to closed

I may not have cleared my cache? It works fine now.

comment:2 @foolswisdom8 years ago

  • Milestone 2.1.1 deleted

comment:3 @novasource8 years ago

  • Milestone set to 2.1.2
  • Resolution invalid deleted
  • Status changed from closed to reopened

Sorry, got to reopen. The problem is back. Nothing substantive has changed on my blog or browsers since it last worked. This is looking like a WordPress bug.

comment:4 @foolswisdom8 years ago

  • Milestone 2.1.3 deleted
  • Resolution set to worksforme
  • Status changed from reopened to closed

novasource, unfortunately without being able to reproduce this issue, I don't know how anyone can help.

comment:5 @novasource8 years ago

  • Priority changed from normal to high
  • Resolution worksforme deleted
  • Status changed from closed to reopened
  • Version changed from 2.1 to 2.1.3

Brand new install of Windows Vista and Firefox. The first time I opened my blog, I logged in to edit. Not only do I get the double spacing issue (per http://trac.wordpress.org/ticket/3822), the formatting buttons don't work. E.g., if I put the cursor on a paragraph and press the unordered list key, it appears that the unordered list is created and immediately reverted. Sometimes it's so fast that the screen doesn't even draw the momentarily-apparent unordered list.

I am changing to high because this makes the product almost unusable to me.

comment:6 @novasource8 years ago

In case it helps, I checked the error console in Firefox. It is reporting numerous warnings and errors. I'll just copy and paste them here:

Warning: Unknown property '_width'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-admin/wp-admin.css?version=2.1.2
Line: 686
Warning: Unknown property '_width'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-admin/wp-admin.css?version=2.1.2
Line: 686
Warning: Unknown property '_margin'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-admin/wp-admin.css?version=2.1.2
Line: 687
Warning: Unknown property '_width'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-admin/wp-admin.css?version=2.1.2
Line: 721
Warning: Unknown property '_margin'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-admin/wp-admin.css?version=2.1.2
Line: 722
Warning: Unknown property 'zoom'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-admin/wp-admin.css?version=2.1.2
Line: 842
Warning: Unknown property '-khtml-opacity'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-admin/wp-admin.css?version=2.1.2
Line: 1249
Warning: Unknown property 'filter'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-admin/wp-admin.css?version=2.1.2
Line: 1250
Warning: Unknown property 'filter'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-includes/js/tinymce/themes/advanced/css/editor_ui.css
Line: 72
Warning: Unknown property 'filter'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-includes/js/tinymce/themes/advanced/css/editor_ui.css
Line: 87
Error: tinyMCE.switchClassSticky is not a function
Source File: http://cambre.biz/blog/wp-includes/js/tinymce/tiny_mce_gzip.php?ver=20061113&theme=advanced&language=&plugins=inlinepopups%2Cautosave%2Cspellchecker%2Cpaste%2Cwordpress%2Cg2image&lang=&index=0
Line: 2871
Warning: Unknown property 'scrollbar-3dlight-color'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-includes/js/tinymce/themes/advanced/css/editor_content.css
Line: 50
Warning: Unknown property 'scrollbar-arrow-color'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-includes/js/tinymce/themes/advanced/css/editor_content.css
Line: 51
Warning: Unknown property 'scrollbar-base-color'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-includes/js/tinymce/themes/advanced/css/editor_content.css
Line: 52
Warning: Unknown property 'scrollbar-darkshadow-color'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-includes/js/tinymce/themes/advanced/css/editor_content.css
Line: 53
Warning: Unknown property 'scrollbar-face-color'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-includes/js/tinymce/themes/advanced/css/editor_content.css
Line: 54
Warning: Unknown property 'scrollbar-highlight-color'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-includes/js/tinymce/themes/advanced/css/editor_content.css
Line: 55
Warning: Unknown property 'scrollbar-shadow-color'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-includes/js/tinymce/themes/advanced/css/editor_content.css
Line: 56
Warning: Unknown property 'scrollbar-track-color'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-includes/js/tinymce/themes/advanced/css/editor_content.css
Line: 57
Warning: Unknown property 'scrollbar-3dlight-color'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-includes/js/tinymce/plugins/wordpress/wordpress.css
Line: 74
Warning: Unknown property 'scrollbar-arrow-color'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-includes/js/tinymce/plugins/wordpress/wordpress.css
Line: 75
Warning: Unknown property 'scrollbar-base-color'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-includes/js/tinymce/plugins/wordpress/wordpress.css
Line: 76
Warning: Unknown property 'scrollbar-darkshadow-color'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-includes/js/tinymce/plugins/wordpress/wordpress.css
Line: 77
Warning: Unknown property 'scrollbar-face-color'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-includes/js/tinymce/plugins/wordpress/wordpress.css
Line: 78
Warning: Unknown property 'scrollbar-highlight-color'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-includes/js/tinymce/plugins/wordpress/wordpress.css
Line: 79
Warning: Unknown property 'scrollbar-shadow-color'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-includes/js/tinymce/plugins/wordpress/wordpress.css
Line: 80
Warning: Unknown property 'scrollbar-track-color'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-includes/js/tinymce/plugins/wordpress/wordpress.css
Line: 81
Warning: Unknown property 'bo2rder-bottom'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-includes/js/tinymce/plugins/spellchecker/css/content.css
Line: 3
Warning: Unknown property 'filter'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-includes/js/tinymce/plugins/spellchecker/css/spellchecker.css
Line: 19
Warning: Unknown property '_width'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-admin/wp-admin.css?version=2.1.2
Line: 680
Warning: Unknown property '_width'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-admin/wp-admin.css?version=2.1.2
Line: 686
Warning: Unknown property '_margin'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-admin/wp-admin.css?version=2.1.2
Line: 687
Warning: Unknown property '_width'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-admin/wp-admin.css?version=2.1.2
Line: 721
Warning: Unknown property '_margin'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-admin/wp-admin.css?version=2.1.2
Line: 722
Warning: Unknown property 'zoom'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-admin/wp-admin.css?version=2.1.2
Line: 842
Warning: Unknown property '-khtml-opacity'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-admin/wp-admin.css?version=2.1.2
Line: 1249
Warning: Unknown property 'filter'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-admin/wp-admin.css?version=2.1.2
Line: 1250

comment:7 @novasource8 years ago

  • Milestone set to 2.1.3
  • Severity changed from normal to major
  • Version changed from 2.1.3 to 2.1.2

Adding milestone and correcting version.

comment:8 @novasource8 years ago

  • Summary changed from Several formatting buttons in editor do not work in FF 2.0.0.1 to Several formatting buttons in editor do not work in FF 2.0.0.3

Fixing title.

comment:9 follow-up: @g30rg3x8 years ago

did you have firefox + noscript (extension)

comment:10 @Nazgul8 years ago

  • Milestone changed from 2.1.3 to 2.3

Bumping the milestone, because of the imminent release of 2.1.3.

comment:11 @JeremyVisser8 years ago

  • Summary changed from Several formatting buttons in editor do not work in FF 2.0.0.3 to Several formatting buttons in editor do not work in Fx 2.0.0.3

Sorry, had to be politically correct here. ;)

comment:12 in reply to: ↑ 9 @novasource8 years ago

  • Milestone changed from 2.3 to 2.2

Replying to g30rg3x:

did you have firefox + noscript (extension)

No extensions. This is just the standard Firefox 2.0.0.3 download accessible by clicking the Download Firefox - Free link in the middle of http://www.mozilla.com/en-US/firefox/.

Is this not possible to be fixed for 2.2? This is a major usability problem.

comment:13 follow-up: @Otto428 years ago

Exactly how do you reproduce this problem? I can't make it happen on my 2.1.2 blog. Admittedly, I am running a lot of plugins and extensions and such, but it appears to work correctly for me.

comment:14 in reply to: ↑ 13 @novasource8 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

Replying to Otto42:

Exactly how do you reproduce this problem? I can't make it happen on my 2.1.2 blog. Admittedly, I am running a lot of plugins and extensions and such, but it appears to work correctly for me.

I just realized the problem is WPG2 2.01. I disabled it, cleared my cache, and went back to the Write page, and the problems described in this ticket went away.

comment:15 @rob1n8 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:16 @rob1n8 years ago

  • Milestone 2.2 deleted
  • Resolution set to invalid
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.