WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#3822 closed defect (bug) (invalid)

Editor shows incorrect vertical spacing with Firefox 2.0.0.3

Reported by: novasource Owned by:
Milestone: Priority: normal
Severity: major Version: 2.1.2
Component: TinyMCE Keywords:
Focuses: Cc:

Description

When editing with Firefox, the enter key produces about 3-4 vertical spaces. Sometimes, but not always, this appears to correctly end up as a <p>.

If I save a draft and reload it, vertical spacing is correct. However, if I click on Code and go back to Visual, the incorrect vertical spacing is sometimes restored.

This problem was duplicated in Firefox 2.0.0.1 with a fresh install of WordPress per 3814.

Change History (14)

comment:1 novasource7 years ago

  • Resolution set to invalid
  • Status changed from new to closed

Something just happened. It works correctly now, and I cannot reproduce. Will reopen if I can consistently reproduce.

comment:2 foolswisdom7 years ago

  • Milestone 2.1.1 deleted

comment:3 novasource7 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

The problem has reappeared even though nothing substantive has changed with my browser or WordPress install.

comment:4 novasource7 years ago

  • Priority changed from normal to high
  • Version changed from 2.1 to 2.1.3

I just did a clean install of Microsoft Windows Vista. The first time I logged into my blog, I entered some text into the editor (alphanumeric and a period) and pressed enter.

Pressing enter caused two paragraph vertical spaces (double vertical spaces) to appear.

If I press backspace, I can delete a single vertical space equivalent to a br. If I hit backspace again, same thing. At that point, I am left with one paragraph (double) space. If I press backspace once more, the one paragraph (double) space is removed.

Saving the entry and previewing it suggests the vertical spacing is normal when I correct it. Interestingly, if I don't correct the vertical spacing before saving it, the vertical spacing is correct in the preview, and it is corrected when I reopen the post for editing.

comment:5 novasource7 years ago

In case it helps, I checked the error console in Firefox. It is reporting numerous warnings and errors. I'll just copy and paste them here:

Warning: Unknown property '_width'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-admin/wp-admin.css?version=2.1.2
Line: 686
Warning: Unknown property '_width'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-admin/wp-admin.css?version=2.1.2
Line: 686
Warning: Unknown property '_margin'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-admin/wp-admin.css?version=2.1.2
Line: 687
Warning: Unknown property '_width'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-admin/wp-admin.css?version=2.1.2
Line: 721
Warning: Unknown property '_margin'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-admin/wp-admin.css?version=2.1.2
Line: 722
Warning: Unknown property 'zoom'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-admin/wp-admin.css?version=2.1.2
Line: 842
Warning: Unknown property '-khtml-opacity'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-admin/wp-admin.css?version=2.1.2
Line: 1249
Warning: Unknown property 'filter'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-admin/wp-admin.css?version=2.1.2
Line: 1250
Warning: Unknown property 'filter'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-includes/js/tinymce/themes/advanced/css/editor_ui.css
Line: 72
Warning: Unknown property 'filter'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-includes/js/tinymce/themes/advanced/css/editor_ui.css
Line: 87
Error: tinyMCE.switchClassSticky is not a function
Source File: http://cambre.biz/blog/wp-includes/js/tinymce/tiny_mce_gzip.php?ver=20061113&theme=advanced&language=&plugins=inlinepopups%2Cautosave%2Cspellchecker%2Cpaste%2Cwordpress%2Cg2image&lang=&index=0
Line: 2871
Warning: Unknown property 'scrollbar-3dlight-color'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-includes/js/tinymce/themes/advanced/css/editor_content.css
Line: 50
Warning: Unknown property 'scrollbar-arrow-color'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-includes/js/tinymce/themes/advanced/css/editor_content.css
Line: 51
Warning: Unknown property 'scrollbar-base-color'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-includes/js/tinymce/themes/advanced/css/editor_content.css
Line: 52
Warning: Unknown property 'scrollbar-darkshadow-color'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-includes/js/tinymce/themes/advanced/css/editor_content.css
Line: 53
Warning: Unknown property 'scrollbar-face-color'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-includes/js/tinymce/themes/advanced/css/editor_content.css
Line: 54
Warning: Unknown property 'scrollbar-highlight-color'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-includes/js/tinymce/themes/advanced/css/editor_content.css
Line: 55
Warning: Unknown property 'scrollbar-shadow-color'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-includes/js/tinymce/themes/advanced/css/editor_content.css
Line: 56
Warning: Unknown property 'scrollbar-track-color'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-includes/js/tinymce/themes/advanced/css/editor_content.css
Line: 57
Warning: Unknown property 'scrollbar-3dlight-color'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-includes/js/tinymce/plugins/wordpress/wordpress.css
Line: 74
Warning: Unknown property 'scrollbar-arrow-color'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-includes/js/tinymce/plugins/wordpress/wordpress.css
Line: 75
Warning: Unknown property 'scrollbar-base-color'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-includes/js/tinymce/plugins/wordpress/wordpress.css
Line: 76
Warning: Unknown property 'scrollbar-darkshadow-color'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-includes/js/tinymce/plugins/wordpress/wordpress.css
Line: 77
Warning: Unknown property 'scrollbar-face-color'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-includes/js/tinymce/plugins/wordpress/wordpress.css
Line: 78
Warning: Unknown property 'scrollbar-highlight-color'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-includes/js/tinymce/plugins/wordpress/wordpress.css
Line: 79
Warning: Unknown property 'scrollbar-shadow-color'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-includes/js/tinymce/plugins/wordpress/wordpress.css
Line: 80
Warning: Unknown property 'scrollbar-track-color'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-includes/js/tinymce/plugins/wordpress/wordpress.css
Line: 81
Warning: Unknown property 'bo2rder-bottom'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-includes/js/tinymce/plugins/spellchecker/css/content.css
Line: 3
Warning: Unknown property 'filter'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-includes/js/tinymce/plugins/spellchecker/css/spellchecker.css
Line: 19
Warning: Unknown property '_width'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-admin/wp-admin.css?version=2.1.2
Line: 680
Warning: Unknown property '_width'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-admin/wp-admin.css?version=2.1.2
Line: 686
Warning: Unknown property '_margin'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-admin/wp-admin.css?version=2.1.2
Line: 687
Warning: Unknown property '_width'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-admin/wp-admin.css?version=2.1.2
Line: 721
Warning: Unknown property '_margin'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-admin/wp-admin.css?version=2.1.2
Line: 722
Warning: Unknown property 'zoom'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-admin/wp-admin.css?version=2.1.2
Line: 842
Warning: Unknown property '-khtml-opacity'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-admin/wp-admin.css?version=2.1.2
Line: 1249
Warning: Unknown property 'filter'. Declaration dropped.
Source File: http://cambre.biz/blog/wp-admin/wp-admin.css?version=2.1.2
Line: 1250

comment:6 novasource7 years ago

  • Milestone set to 2.1.2
  • Severity changed from normal to major
  • Version changed from 2.1.3 to 2.1.2

Correcting version and adding milestone.

comment:7 novasource7 years ago

  • Summary changed from Editor shows incorrect vertical spacing with Firefox 2.0.0.1 to Editor shows incorrect vertical spacing with Firefox 2.0.0.3

Every time I press backspace while editing, I get this error:
Error: tinyMCE.switchClassSticky is not a function
Source File: http://cambre.biz/blog/wp-includes/js/tinymce/tiny_mce_gzip.php?ver=20061113&theme=advanced&language=&plugins=inlinepopups%2Cautosave%2Cspellchecker%2Cpaste%2Cwordpress%2Cg2image&lang=&index=0
Line: 2871

comment:8 novasource7 years ago

  • Component changed from Administration to TinyMCE
  • Milestone changed from 2.1.2 to 2.1.3

Correction: almost any time I do anything, even alt-tabing between my editor window and another window, I get this error:

Error: tinyMCE.switchClassSticky is not a function
Source File: http://cambre.biz/blog/wp-includes/js/tinymce/tiny_mce_gzip.php?ver=20061113&theme=advanced&language=&plugins=inlinepopups%2Cautosave%2Cspellchecker%2Cpaste%2Cwordpress%2Cg2image&lang=&index=0
Line: 2871

If I click somewhere in the edited document, I get multiple of those errors all at once.

comment:9 follow-up: Nazgul7 years ago

  • Milestone changed from 2.1.3 to 2.3
  • Priority changed from high to normal

Could this be a Vista specific problem? Because as far as I know, you're the only one with these issues so far?

I'm bumping the milestone, because the 2.1.3 release is imminent and this won't make it in there in time.

comment:10 foolswisdom7 years ago

Thanks for the detailed bug report novasource . Please consider just including a few lines of the errors next time, and attaching a more complete log instead of pasting it inline. Thanks again.

comment:11 in reply to: ↑ 9 novasource7 years ago

Replying to Nazgul:

Could this be a Vista specific problem? Because as far as I know, you're the only one with these issues so far?

I'm sure it's not. Happens on my Windows XP laptop with Firefox 2.0.0.3.

comment:12 Otto427 years ago

novasource: Given the issue here and the issues you describe in #3821 , I'm tempted to suggest that this is a problem only with your site. The errors you describe as seeing in the console do not happen in my browser or my sites. They sorta suggest that you have something else running on the blog which is interfering.

For example: "tinyMCE.switchClassSticky is not a function"...

The word "sticky" does not appear *anywhere* in Wordpress 2.1.2. So where that's coming from, I have no idea.

comment:13 novasource7 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed

I just realized the problem is WPG2 2.01. I disabled it, cleared my cache, and went back to the Write page, and the problem described in this ticket went away. Re-enabling it and clearing my cache again brings back the problem. I'll take this up with the WPG2 guys.

comment:14 rob1n7 years ago

  • Milestone 2.3 deleted
Note: See TracTickets for help on using tickets.