WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 2 years ago

#38222 closed defect (bug) (fixed)

Customize themes section doesn't show theme screenshots, border hover issues

Reported by: celloexpressions Owned by: celloexpressions
Milestone: 4.7 Priority: high
Severity: normal Version: 4.7
Component: Customize Keywords: has-patch
Focuses: javascript Cc:

Description

There are some odd visual regressions in the themes section in trunk. This'll be replaced in #37661, but this ticket is to track those in case that project doesn't make it into 4.7. See https://wordpress.slack.com/archives/core-customize/p1475517778001564.

Attachments (3)

trac-38222_1.diff (824 bytes) - added by delawski 2 years ago.
trac-38222_2.diff (1.6 KB) - added by delawski 2 years ago.
border issue.mov (478.1 KB) - added by westonruter 2 years ago.

Download all attachments as: .zip

Change History (14)

#1 @celloexpressions
3 years ago

  • Owner set to celloexpressions
  • Status changed from new to assigned

This ticket was mentioned in Slack in #core by jeffpaul. View the logs.


3 years ago

This ticket was mentioned in Slack in #core-customize by celloexpressions. View the logs.


3 years ago

#4 @celloexpressions
3 years ago

  • Milestone 4.7 deleted
  • Resolution set to invalid
  • Status changed from assigned to closed

No idea what happened here, but invalidated by [38813].

#5 @ocean90
2 years ago

  • Keywords needs-patch added
  • Milestone set to 4.7
  • Priority changed from low to high
  • Resolution invalid deleted
  • Status changed from closed to reopened

Needs a patch because of [39140].

This ticket was mentioned in Slack in #core-customize by mckernanin. View the logs.


2 years ago

#7 @mckernanin
2 years ago

I did some digging into the missing screenshots.
It appears that renderScreenshots() is no longer being called on opening the panel. In 4.6.1, this was done in onChangeExpanded(), line 977. renderScreenshots() is still bound to the filter field, if you type something into the theme search box then all of the screenshots will load.
I'm not sure where this should be hooked back in, but I'm happy to assist however I can!

Related to [34391]

Last edited 2 years ago by mckernanin (previous) (diff)

#8 @delawski
2 years ago

  • Focuses javascript added
  • Keywords has-patch added; needs-patch removed

@celloexpressions - Just as @mckernanin noticed, Themes panel's expand routine is missing a call to renderScreenshots() and scroll event listener. I've added missing lines and issued a PR:

https://github.com/xwp/wordpress-develop/pull/195

There's also a diff file attached to this ticket.

#9 @delawski
2 years ago

I've completely missed the styling issues in my initial patch. I've just submitted a new patch that fixes both screenshots rendering and CSS issues (the PR is updated as well)

#10 @mckernanin
2 years ago

Patch looks good, fixes both issues.

#11 @westonruter
2 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

In 39153:

Customize: Fix loading of theme screenshots in themes section and remove erroneous borders on hover.

Fixes regressions introduced in [38648].

Props delawski, mckernanin.
See #34391.
Fixes #38222.

Note: See TracTickets for help on using tickets.