WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#3825 closed defect (bug) (worksforme)

problem with conflict of permalinks in multiple instalations

Reported by: thomask Owned by:
Milestone: Priority: low
Severity: normal Version: 2.1
Component: General Keywords: permalinks
Focuses: Cc:

Description

confirmed bug in 2.1, was not in older versions, see http://wordpress.org/support/topic/106386?replies=2

I got two separate wordpress instalation
http://www.kapler.cz
http://www.kapler.cz/tibetska-doga

when I run permalinks only on the first one, it works fine, but when i turn permalinks on also on the second one, it "jumps" to the 404 page (with right path e.g. http://www.kapler.cz/tibetska-doga/my-article-name
but with layout (template, header..) of the first instalation.

I have just did reinsatalation of the second blog to 2.1, prior this reinstalation the permalinks were working normaly. I tried to delete both .htaccess and make permalinks live again, but nothing helps.

Change History (4)

comment:1 foolswisdom7 years ago

  • Milestone changed from 2.1.1 to 2.3
  • Priority changed from normal to low

That is an unusual configuration, and may be a limitation of htaccess rewrite based perma-links

comment:2 rob1n7 years ago

Possibly try adding a rewrite rule to exclude /tibetska-dog/?(.*) from the root install's htaccess?

But, as fools said, this is an unusual configuration and I have had no problems running an install at / and then at /wptest.

comment:3 markjaquith7 years ago

  • Milestone 2.3 deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Cannot reproduce

comment:4 Viper007Bond7 years ago

Should work fine as the root's install detects the folder tibetska-doga exists and so ignores doing mod_rewrite and tibetska-doga's .htaccess file takes priority over the root's (assuming it's actually there, which may have been the problem).

Note: See TracTickets for help on using tickets.