WordPress.org

Make WordPress Core

Opened 15 years ago

Closed 14 years ago

#3828 closed defect (bug) (worksforme)

Buttons don't appear in WYSIWYG editor after upgrading

Reported by: Gesu Owned by:
Milestone: Priority: normal
Severity: major Version: 2.1
Component: Administration Keywords: WYSIWYG, editor
Focuses: Cc:

Description

It looks like WordPress 2.1 has some problem showing buttons in WYSIWYG editor, after upgrading from a 1.x version.

This has been discussed in several threads on support forums, for example:

http://wordpress.org/support/topic/101817

http://wordpress.org/support/topic/101773

My experience:

  • Deleting all previous files when upgrading from WP 1.x did not work (I did it several times);
  • Disabling plugins did not work;
  • The option under "User -> Profile" to enable visual editor was already checked;
  • Removing and then adding again the "www" prefix in the blog URL address, under "Options" page, worked for Internet Explorer and Mozilla Firefox, but not for K-meleon (I deleted browser cache but it was useless);

Here my hosting details:

  • Apache version - 1.3.37 (Unix)
  • PHP version - 4.4.4
  • MySQL version - 4.1.21-standard-log

Since I've seen a lot of people with the same problem, i suppose it can be considered a bug (I hope there're no other tickets about this issue, if there are, I apologize, I searched a lot but I could not find them).

Change History (5)

#1 follow-up: @foolswisdom
15 years ago

  • Milestone 2.3 deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Hi Gesu, thank you for participating in WordPress!

Closing ticket as WORKSFORME, as I do not see a fixable bug reported here. If you have a reproducible scenario please reopen -- a problem specific to K-meleon would sound like a bug with the browser.

When I have previously looked at those support topics, it seems like their are a variety of issues reported, and they are resolved by fixing in their environment.

#2 in reply to: ↑ 1 @Gesu
15 years ago

Hi foolswisdom,

First of all thank you for your answer :-)

Well, I agree that there are a variety of issues, but you must admit that the very problem is always the same: in WP 2.1 the visual editor appears to be broken. And what matters is that the solution has not always been to fix the environment: in my case, and not only mine, I had to delete the www prefix from the Options page, then adding it again. This shows, in my very humble opinion, that the problem is not related to the browser used (I had the same problem with Firefox), but that there's something wrong in WordPress. I understand your point, and accept it, but what I think is that unfortunately the problem is real, even if it seems to appear randomly, and I hope that anyway it'll be fixed in a new WP version (with a TinyMCE update, or in another way).

Sorry in any case, if I wasted your time.

Thank you again :-)

#3 @foolswisdom
15 years ago

Hi Gesu,

Time not wasted at all!

Without being able to be duplicated, I don't see someone being able to fix it, and so a bug report will just sit here rotting.

I have tried to duplicate the issue a number of times, but so far with no success.

"in my case, and not only mine, I had to delete the www prefix from the Options page"

Yes, it it resolved the symptom, but it does not necessarily reveal the cause of the problem.

#4 @dragosc
14 years ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened
  • Version changed from 2.1 to 2.2.1

Hello,

I have Wordpress 2.2.1 installed and there are problems with WYSIWYG editor under IE 6 / Windows. I tried in FF, Opera and Safari and it is working. This test was made on 5 different Windows machines.

The error is: “realTinyMCE is undefined” on “wp-admin/post-new.php”.

This happens on a clean install without any plugin activated and only on IE6. The only way it comes to live is by using CTRL + F5 on this page. All buttons will be in their place and everything goes smooth.

Hosting details:
Apache: 1.3.33 (Unix)
PHP: 4.4.7
MySQL API version: 4.0.25

Thank you for your time,

Dragos

#5 @Viper007Bond
14 years ago

  • Resolution set to worksforme
  • Status changed from reopened to closed
  • Version changed from 2.2.1 to 2.1

Thanks for participating in helping make WordPress better!

However, please open your own ticket rather than re-opening a really ticket: http://trac.wordpress.org/newticket

But please upgrade to the latest version first to ensure this isn't related to an already fixed bug. ;)

Thanks again.

Note: See TracTickets for help on using tickets.