WordPress.org

Make WordPress Core

Opened 3 years ago

Last modified 3 years ago

#38300 reopened defect (bug)

Got a PHP warning: class-wp-xmlrpc-server.php L596: array_unshift() ...

Reported by: kmvan Owned by:
Milestone: Awaiting Review Priority: normal
Severity: normal Version: 4.6.1
Component: XML-RPC Keywords:
Focuses: Cc:
PR Number:

Description

Sometimes the php_error.log file got a warning:

PHP Warning:  array_unshift() expects parameter 1 to be array, null given in /wp-includes/class-wp-xmlrpc-server.php on line 596
<?php
public function wp_getUsersBlogs( $args ) {
        // If this isn't on WPMU then just use blogger_getUsersBlogs
        if ( !is_multisite() ) {
                array_unshift( $args, 1 );
                return $this->blogger_getUsersBlogs( $args );
        }
...
}

The $args is NULL, it doesn't matter?

Change History (2)

#1 @galbaras
3 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Possible duplicate of #29750?

I'm getting this too, 5 months after #29750 was marked as "fixed".

Last edited 3 years ago by galbaras (previous) (diff)

#2 @galbaras
3 years ago

  • Resolution duplicate deleted
  • Status changed from closed to reopened
Note: See TracTickets for help on using tickets.