WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 8 months ago

#38330 closed enhancement (duplicate)

Upload Image with metadatas

Reported by: whoaloic Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Media Keywords:
Focuses: Cc:
PR Number:

Description

Hello,
If you download an image, it might have some meta title and WP will snack that up for the title field, I do not want this kind of behavior as the files are named precisely for a reason.
Why WP takes the metadatas as title and caption?

Would it be possible to get default image title with filename even if there are exif datas?
Or better remove exif datas when uploading images?

Any help would be really appreciated.
Kind regards

Change History (1)

#1 @desrosj
8 months ago

  • Component changed from General to Media
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version 4.6.1 deleted

Hi @whoaloic,

Welcome to Trac! My apologies that it took someone so long to get back to you.

Even though this was opened before #40782, I am going to close this out as a duplicate of that ticket because there is much more discussion there. Please review that ticket, and add any further thoughts there. But, the resolution for that one is that this behavior is unlikely to be changed.

Note: See TracTickets for help on using tickets.