WordPress.org

Make WordPress Core

Opened 8 months ago

Closed 8 months ago

#38335 closed defect (bug) (fixed)

TinyMCE: wplink throws error when opening it with nothing selected in IE

Reported by: azaozz Owned by: azaozz
Milestone: 4.7 Priority: normal
Severity: normal Version:
Component: TinyMCE Keywords:
Focuses: Cc:

Description

Can see it in IE8, IE11 and even in Edge. Seems caused by the way we try to store and then restore the selection.

Change History (1)

#1 @azaozz
8 months ago

  • Owner set to azaozz
  • Resolution set to fixed
  • Status changed from new to closed

In 38808:

TinyMCE wplink:

  • Remove the calls to getBookmark() and moveToBookmark() in IE. This is handled automatically when blurring and focusing the editor.
  • When inserting a link, move it out of the caret position element. If not, it may be removed with that element on clean-up before save.

Fixes #38335.

Note: See TracTickets for help on using tickets.