WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#38359 closed feature request (duplicate)

Add a message telling the user that the cron is not working

Reported by: enej Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.6.1
Component: Cron API Keywords:
Focuses: Cc:
PR Number:

Description

Currently if a site's cron doesn't work as expected for one reason or another (a host that blocks loopback request) the user won't know that something is broken until they notice things like scheduled posts, core autoupdates or other features not working as expected.

It would be great to show a message to the user that their cron is not working and provide them with ways of fixing it.

The way to detect that cron is broken would be to see a delay in when a hook is supposed to be scheduled and when it goes out. So if a hook has been scheduled but is not cleared by cron for more then a few days.

Change History (4)

#1 @swissspidy
3 years ago

It would be great to show a message to the user that their cron is not working and provide them with ways of fixing it.

Can you elaborate on that? How would a non-technical user solve this?

#2 @jipmoors
3 years ago

I like the idea and perhaps there are some alternative solutions to explore.

An email message would sound a bit more logical, as @swissspidy noted you need to reach the right person.

Having a cron-verification/testing "service" wouldn't be a bad idea either, knowing the unreliable state of webhosters on this functionality.

#3 @enej
3 years ago

@swissspidy
We could point the user to a codex article that would have a list of things to try.

We could add a filter to the whole thing and hosts could add their own messages.

@jipmoors

An email message would sound a bit more logical, as @swissspidy noted you need to reach the right person.

Yes, reaching the right person is critical. I think email has its own problems though. (It could not be working/ go into the spam folder)

I think the person that does the site updates should see the message since they are most likely to be the person that is most technical.

#4 @SergeyBiryukov
3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #23133.

Note: See TracTickets for help on using tickets.