WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#38366 closed defect (bug) (duplicate)

Hide "Previously uploaded" and "Suggested" when list is empty

Reported by: ocean90 Owned by: celloexpressions
Milestone: Priority: normal
Severity: normal Version: 4.6
Component: Customize Keywords: has-patch
Focuses: javascript Cc:

Description

It seems like this issue was introduced in 4.6.

  • Go to the header image control in the customizer
  • Make sure that you're customizing a theme with custom header support
  • Notice the "Previously uploaded" and "Suggested" headlines without a list of images

Attachments (3)

38366.png (74.9 KB) - added by ocean90 4 years ago.
38366.diff (558 bytes) - added by Fencer04 4 years ago.
Hide headers when suggested or default header images aren't available.
38366.1.diff (603 bytes) - added by Fencer04 4 years ago.
New version of patch created from the root for easier installation.

Download all attachments as: .zip

Change History (9)

@ocean90
4 years ago

#1 @ocean90
4 years ago

  • Focuses javascript added

trunk/src/wp-includes/js/customize-views.js?rev=36639&marks=196#L173: $.prev() doesn't contain .customize-control-title anymore, it's now div.customize-control-notifications-container.

#2 @westonruter
4 years ago

  • Milestone changed from Awaiting Review to 4.7
  • Owner set to celloexpressions
  • Status changed from new to assigned

@Fencer04
4 years ago

Hide headers when suggested or default header images aren't available.

#3 @Fencer04
4 years ago

  • Keywords has-patch added; needs-patch removed

I added a patch that updates the selector for the header text based on the new notification div that is between the list and the title of the list.

This ticket was mentioned in Slack in #core-customize by fencer04. View the logs.


4 years ago

@Fencer04
4 years ago

New version of patch created from the root for easier installation.

#5 @westonruter
4 years ago

#38561 was marked as a duplicate.

#6 @westonruter
4 years ago

  • Milestone 4.7 deleted
  • Resolution set to duplicate
  • Status changed from assigned to closed

Duplicate of #38561.

I got my duplicates confused. Fixed in [39145].

Note: See TracTickets for help on using tickets.