WordPress.org

Make WordPress Core

Opened 14 years ago

Closed 5 years ago

Last modified 5 years ago

#3842 closed enhancement (fixed)

Should make nofollow implementation cleaner and easier to remove

Reported by: markjaquith Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.1.1
Component: Comments Keywords:
Focuses: Cc:

Description

rel="nofollow" didn't appreciably stop comment spam, and there are many arguments for why it is a bad idea (and not just a failed idea). We should consider axing it.

Change History (26)

#1 follow-up: @matt
14 years ago

I don't think the purpose was ever to stop comment spam, it was to signify which links on a page were externally generated vs ones with authorial intent.

There is also the question of whether removing it would increase comment spam, since WP blogs would be a "tastier" target since the links wouldn't be nofollowed.

#2 @tereshchenko
14 years ago

Can you make a setting for this? Enable it by default, and let users disable it (I currently patch WordPress source to disable it).

Or - even better - make it a plug-in! And of course, include it with WordPress (so it can be easily turned on/off).

#3 @rob1n
14 years ago

http://kimmo.suominen.com/sw/dofollow/

Whether or not this makes it into the core, patching your core files makes upgrading less feasible and that plugin takes care of it all.

I am +1 on removing nofollow. What has it done? Hardly anything that I can see. Comment spam has if anything, by Akismet's own graphs, increased multiple times over. If people wanted to use nofollow, I'm sure someone could come up with a plugin to add rel="nofollow", but I don't think nofollow should be in the core.

#4 @drmike
14 years ago

+1 on removing although I would think it would generate bad press from the community. "Wordpress likes spam!" and crud like that.

Gotta admit though I like the idea of getting links back to my site from all of the comments that I leave. I may not be a student of SEO but I'm not going to pass up links.

#5 @westi
14 years ago

My personal feeling on this is that all nofollow'ing should be moved to filters added in default_filters which can then be removed if required with a simple plugin.

#6 @Otto42
14 years ago

I thought it was a filter already, except for a few special cases.

In default-filters.php, there's this line:

add_filter('pre_comment_content', 'wp_rel_nofollow', 15);

Now, it should probably be removed from the make_clickable() function. Or, at least, all the nofollow addition on comments should be moved to one location somehow.

#7 in reply to: ↑ 1 @markjaquith
14 years ago

Replying to matt:

I don't think the purpose was ever to stop comment spam, it was to signify which links on a page were externally generated vs ones with authorial intent.

The title of Google's announcement post was "Preventing comment spam" :-)

There is also the question of whether removing it would increase comment spam, since WP blogs would be a "tastier" target since the links wouldn't be nofollowed.

That's certainly possible... in which case blog engines are stuck with it, as the first one to drop it gets penalized. Grr.

#8 @andy
14 years ago

Until somebody measures the difference made by nofollow, or the consequences of removing it from blogs (anecdotal evidence being inadmissible), there is little to talk about.

Such a test should use regression analysis on a statistically significant sample population. Anybody interested in doing that?

#9 @Otto42
14 years ago

I've always found the nofollow argument interesting. The arguments basically boil down to this:

Arguments for nofollow:

  • It helps prevent comment spam
  • It lets search engines like Google distinguish between intentional links and unintentional ones, thus lowering blog PageRank's (since blogs tend to use a lot of inter-blog linking).

Arguments against nofollow:

  • It does not help prevent comment spam
  • It lets search engines like Google distinguish between intentional links and unintentional ones, thus lowering blog PageRank's (since blogs tend to use a lot of inter-blog linking).

See the fun there? What's interesting to me about this is that the arguments disagree on whether or not it helps prevent spam, but absolutely agree on the overall effect it has with regard to blog's PageRank.

Think of it like this: If I were to go and comment on a blog and leave a link to my own blog (like everybody does), then without nofollow, that link is now enhancing my own PageRank.

The question is: Should it do so? Obviously people disagree on this topic, because it's not a technical question.

Personally, I think that nofollow helps overall, because the alternative is for Google and other search engines to segregate blogs into a separate blogsearch, so as to eliminate blogs with high PageRank taking over virtually all of their top search results. Google started to do this (blogsearch.google.com) but never really seemed to complete it. Probably because it became unnecessary.

Still, pulling the nofollow rel all together into one filter instead of having it in 3 or 4 places would make sense regardless of whether it's enabled by default or not.

#10 @markjaquith
14 years ago

Well said, all around, Otto42. Patches that make nofollow implementation cleaner and easier to remove will be appreciated.

#11 @foolswisdom
14 years ago

  • Milestone changed from 2.2 to 2.4

#12 @foolswisdom
14 years ago

  • Summary changed from Eliminate rel="nofollow" to Should make nofollow implementation cleaner and easier to remove

#13 @rob1n
14 years ago

  • Milestone changed from 2.4 to 2.2
  • Owner changed from anonymous to rob1n
  • Priority changed from low to normal
  1. Make it a filter
  1. Have an option in the admin to enable/disable it

#14 @rob1n
14 years ago

  • Milestone changed from 2.2 to 2.3

#15 @foolswisdom
13 years ago

  • Milestone changed from 2.3 to 2.5 (future)

#16 @rob1n
13 years ago

  • Owner rob1n deleted

#17 @minusonebit
12 years ago

There needs to be an option to disable this on a link-by-link basis as well as a global setting - the functionality It should not be summarily removed.

#18 @pauamma
11 years ago

  • Milestone changed from 2.9 to Future Release

#19 @Denis-de-Bernardy
11 years ago

  • Component changed from Administration to Comments

#20 follow-up: @Denis-de-Bernardy
11 years ago

see also #9959

#22 in reply to: ↑ 20 @dilbert4life
10 years ago

  • Version changed from 2.1.1 to 3.1

It is easy to remove, add

remove_filter('pre_comment_content', 'wp_rel_nofollow', 15);

to your themes function.php - however, the function itself isn't very good, as it can add multiple rel attributes if a separate rel is already defined, like rel="external". See #9959 - working on a patch

#23 @SergeyBiryukov
9 years ago

  • Version changed from 3.1 to 2.1.1

Version number is there to track when the bug was introduced/reported.

#24 @ocean90
7 years ago

  • Keywords nofollow spam rel comments trackbacks removed

#25 @rachelbaker
5 years ago

  • Resolution set to fixed
  • Status changed from new to closed

Now that #9959 has been fixed, the wp_rel_nofollow filter can be removed from pre_comment_content and will properly handle multiple rel attributes.

Closing this ticket, that hasn't had any real movement in over 4 years.

#26 @rachelbaker
5 years ago

  • Milestone Future Release deleted
Note: See TracTickets for help on using tickets.