WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#3847 closed defect (bug) (fixed)

Spell check does not work in Firefox 2.0.0.3

Reported by: novasource Owned by:
Milestone: 2.2 Priority: normal
Severity: major Version: 2.1.2
Component: TinyMCE Keywords:
Focuses: Cc:

Description

When editing a blog post with Firefox 2.0.0.1, spell check does not work. Regardless of erroneous words present, clicking the "Toggle spellchecker" icon always returns a dialog saying "No misspellings found."

Attachments (1)

3847.diff (516 bytes) - added by dancoulter 7 years ago.

Download all attachments as: .zip

Change History (19)

comment:1 foolswisdom7 years ago

Confirmed bug
ENV: WP trunk r4929

comment:2 follow-ups: dancoulter7 years ago

  • Keywords has-patch added

Added a property to allow the Firefox built-in spell checker to work.

dancoulter7 years ago

comment:3 in reply to: ↑ 2 ; follow-up: dancoulter7 years ago

  • Keywords has-patch removed

Replying to dancoulter:

I miss-read this ticket. I am not having problems with WP 2.1.1 and Firefox 2.0.0.1 using the built in TinyMCE spellcheck. Ignore the patch file I uploaded.

comment:4 foolswisdom7 years ago

  • Component changed from General to TinyMCE

comment:5 novasource7 years ago

  • Summary changed from Spell check does not work in Firefox 2.0.0.1 to Spell check does not work in Firefox 2.0.0.1 or 2.0.0.2

Also doesn't work in 2.0.0.2

comment:6 in reply to: ↑ 2 novasource7 years ago

Replying to dancoulter:

Added a property to allow the Firefox built-in spell checker to work.

The patch didn't change anything for me.

comment:7 in reply to: ↑ 3 priv7 years ago

Replying to dancoulter:

Replying to dancoulter:

I miss-read this ticket. I am not having problems with WP 2.1.1 and Firefox 2.0.0.1 using the built in TinyMCE spellcheck. Ignore the patch file I uploaded.

No Problem +1(Firefox 2.0.0.2 and Wordpress 2.1.1), the spellchecker of TinyMCE is working fine here.

comment:8 follow-up: Otto427 years ago

Few things:

-The built-in firefox spell checker is disabled by default. I have a plugin to fix this here: http://ottodestruct.com/blog/2007/01/26/enable-firefox-spell-checking-in-wordpress-21/
It's a simple patch to enable this by default.

-The spell checker in TinyMCE current tries the server's pspell functionality. Failing that, it tries to use Google for spell checking. As noted in #3857, that does not work, but there's a newer version available which does.

The combination of both these fixes should eliminate these issues.

comment:9 in reply to: ↑ 8 novasource7 years ago

-The built-in firefox spell checker is disabled by default. I have a plugin to fix this here: http://ottodestruct.com/blog/2007/01/26/enable-firefox-spell-checking-in-wordpress-21/
It's a simple patch to enable this by default.

Thanks! I would rather use Firefox's built in spell checker, so I will enable this module.

-The spell checker in TinyMCE current tries the server's pspell functionality. Failing that, it tries to use Google for spell checking. As noted in #3857, that does not work, but there's a newer version available which does.

Huh, I am on 1and1.com. I wonder if they have pspell avaiable?

comment:10 novasource7 years ago

I just ran a WireShark sniff, and the spell check only does port 80 with my blog host. It does not port 80 to any other servers.

comment:11 foolswisdom7 years ago

  • Milestone changed from 2.1.3 to 2.2

comment:12 follow-up: novasource7 years ago

  • Severity changed from normal to major
  • Version changed from 2.1.1 to 2.1.2

Updating version. Still broken with 2.1.2.

comment:13 in reply to: ↑ 12 ; follow-up: Nazgul7 years ago

Replying to novasource:

Updating version. Still broken with 2.1.2.

A new version of the spellchecker went into trunk. Could you try and see if that fixed your problem?

comment:14 novasource7 years ago

  • Summary changed from Spell check does not work in Firefox 2.0.0.1 or 2.0.0.2 to Spell check does not work in Firefox 2.0.0.3

Just as an FYI, I closed a few tickets because they were a problem with WPG2 2.01 plugin. For the record, this ticket was not resolved by disabling WPG2 and clearing my cache.

comment:15 in reply to: ↑ 13 ; follow-up: novasource7 years ago

Replying to Nazgul:

Replying to novasource:

Updating version. Still broken with 2.1.2.

A new version of the spellchecker went into trunk. Could you try and see if that fixed your problem?

Sorry, I'm not really familiar with how to do that. Are there any guides? (It's not lack of skills; I just don't know where to begin looking.)

comment:16 in reply to: ↑ 15 ; follow-up: Nazgul7 years ago

Replying to novasource:

Replying to Nazgul:

A new version of the spellchecker went into trunk. Could you try and see if that fixed your problem?

Sorry, I'm not really familiar with how to do that. Are there any guides? (It's not lack of skills; I just don't know where to begin looking.)

The easiest way is through the nightly builds:
http://wordpress.org/download/nightly/

If you try one of those, don't forget to use a new database, as downgrading without restoring database backups is not supported.

comment:17 in reply to: ↑ 16 ; follow-up: novasource7 years ago

Replying to Nazgul:

Replying to novasource:

Replying to Nazgul:

A new version of the spellchecker went into trunk. Could you try and see if that fixed your problem?

Sorry, I'm not really familiar with how to do that. Are there any guides? (It's not lack of skills; I just don't know where to begin looking.)

The easiest way is through the nightly builds:
http://wordpress.org/download/nightly/

If you try one of those, don't forget to use a new database, as downgrading without restoring database backups is not supported.

I got the latest build, and it seems to work. I like that spellcheck a lot better.

comment:18 in reply to: ↑ 17 foolswisdom7 years ago

  • Resolution set to fixed
  • Status changed from new to closed

Replying to novasource:

I got the latest build, and it seems to work. I like that spellcheck a lot better.

Closing as fixed.

Note: See TracTickets for help on using tickets.