WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 months ago

Last modified 3 months ago

#38473 closed enhancement (duplicate)

Additional hook for users list table navigation area

Reported by: antonioeatgoat Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Users Keywords: has-patch
Focuses: administration Cc:

Description

A similar situation has been already discussed for class-wp-posts-list-table.php and manage_posts_extra_tablenav action, here: https://core.trac.wordpress.org/ticket/30341#no0.

The extra_tablenav() function in class-wp-users-list-table.php provides a hook for adding extra filtering options (restrict_manage_users), but there's no way to add extra markup (links, buttons, additional help text, etc.) after the 'Filter' button. I propose adding an additional hook to allow additional markup to be added here.
Adding a hook here may only have fringe use cases, but I don't see a reason not to include it as it won't affect any existing functionality and will make the post and page list tables just a little bit more extensible.

Attachments (1)

The_extra_tablenav___function_in_class_wp_users_list_table_php_provides_a_hook_for_adding_.patch (779 bytes) - added by antonioeatgoat 3 years ago.
Added the hook

Download all attachments as: .zip

Change History (4)

#1 @antonioeatgoat
3 years ago

  • Keywords has-patch added

#2 @desrosj
3 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #36990.

Hi @antonioeatgoat,

Thanks for this ticket, and welcome to Trac! I'm sorry that it took so long to receive a response.

It appears that this filter was already introduced in [40974], so I am going to close this out as a duplicate. Thanks for the great suggestion!

#3 @desrosj
3 months ago

  • Version 4.7 deleted
Note: See TracTickets for help on using tickets.