WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 17 months ago

#38509 closed defect (bug) (worksforme)

WordPress 4.6.1 bug - updating posts in visual mode, corrupts them

Reported by: rsspanic Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.6.1
Component: Editor Keywords:
Focuses: Cc:

Description

Hi, this is related to ticket https://core.trac.wordpress.org/ticket/38269
and we have a clearer knowledge of what is happening. It is very simple: straight after the 4.6.1 update, if we update (save) posts while in visual mode, wordpress messes up the HTML formatting, visually splitting the post and pushes all links to the bottom. This took us many hours to fix. From then on we only save in text mode, and this works. But how can we solve this problem? we are using Designwall Focus Theme 1.08. Even if the theme or one of our plugins is causing this problem, its clearly due to a conflict with the 4.6.1 update. (never had this problem before and we didn't add any plugins during the update).

How can we diagnose this... thanks

Change History (2)

#1 @Clorith
4 years ago

Hi,

As described in #38269, you will have to disable any plugins and use a default theme (such as Twenty Sixteen) to see if the problem remains, if not enable one thing at a time until it returns to identify the source of the problems.

One quick note is that your theme is quite outdated (12 versions as of writing this), and is currently on version 1.3.1, make sure that all plugins and themes are also up to date to ensure it's no a compatibility error that has already been resolved.

#2 @desrosj
17 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed
  • Summary changed from Wordpress 4.6.1 bug - updating posts in visual mode, corrupts them to WordPress 4.6.1 bug - updating posts in visual mode, corrupts them

Ha @rsspanic,

I am going to close this out as worksform. As @Clorith detailed on #38269, this was most likely an issue with your plugin or theme, especially since it was not reported by anyone else.

If you are still experiencing this issue, please reopen with more details to help reliably reproduce the issue.

Note: See TracTickets for help on using tickets.